PROBLEM

Für Portal for ArcGIS kann mit dem Dienstprogramm webgisdr keine Sicherung erstellt werden da der Zugriff auf Elemente im Inhaltsverzeichnis nicht möglich ist

Last Published: January 1, 2021

Beschreibung

Beim Ausführen des Dienstprogramms "webgisdr" zum Sichern von Portal for ArcGIS tritt ein Fehler auf, und es wird folgende Fehlermeldung angezeigt:

Error: { "error":{ "code":500, "details": null, "message": "Failed to export site. Export of the Portal repository failed. \\\\PortalDirectory\\arcgisportal\\content\\items\\" } }

Ursache

Portal for ArcGIS kann den Speicherort der jeweiligen Elementdaten, die gesichert werden sollen, nicht finden, da das Element im Inhaltsverzeichnis von Portal nicht mehr vorhanden ist.

Wenn ein Service mit Feature-Zugriffsfunktionen in einer Verbundumgebung als gehosteter Service veröffentlicht wird, geschieht Folgendes:

  • Die Daten werden in den ArcGIS Data Store vom Typ "relational" kopiert.
  • Auf dem Hosting-Server des Portals wird ein gehosteter Feature-Service erstellt.
  • Im Portal wird ein gehostetes Feature-Layer-Element erstellt.

Wenn der Hosting-Server entfernt oder nach einem Upgrade nicht ordnungsgemäß konfiguriert wird, kann es vorkommen, dass ein Element im Inhaltsverzeichnis angezeigt wird, jedoch nicht aufgerufen werden kann. Beim Löschen dieses Elements tritt ein Fehler auf, und beim Löschen des Elementordners im Inhaltsverzeichnis wird der Ordner nicht entfernt. Durch erneutes Indizieren lässt sich das Problem nicht beheben.

Lösung oder Problemumgehung

Beheben Sie das Problem mit dem folgenden Workaround.

  1. Navigieren Sie zur Admin-URL von Portal for ArcGIS. Die URL lautet:
https://<Computername>.<Domäne>.com/<webadaptorhost>/portaladmin
  1. Navigieren Sie zu Verbund > Server > Servername >Aktualisieren. Wählen Sie in der Dropdown-Liste Serverrolle die Option Hosting-Server aus, und klicken Sie auf Server aktualisieren.
  2. Starten Sie Windows-Dienste, und suchen Sie nach dem Service "Portal for ArcGIS". Klicken Sie mit der rechten Maustaste auf den Service, und wählen Sie Stoppen aus.
  3. Falls der Inhaltsordner gelöscht wurde, stellen Sie den gelöschten Ordner aus dem Windows-Papierkorb wieder her.
Hinweis: Bei Elementen ohne wiederherzustellende Inhaltsorder, erstellen Sie einen neuen Ordner mit demselben Inhaltselement-ID-Namen und kopieren alle Unterordner aus einem anderen Element.
  1. Starten Sie Windows-Dienste, und suchen Sie nach dem Service "Portal for ArcGIS". Klicken Sie mit der rechten Maustaste auf den Service, und wählen Sie Starten aus.
  2. Navigieren Sie zur Inhaltsseite von Portal for ArcGIS, und löschen Sie die jeweiligen Elemente. Der Löschvorgang war erfolgreich, wenn Sie über Portal auf das Element zugreifen können.
  3. Führen Sie das Dienstprogramm "webgisdr" erneut aus, um die Sicherung von Portal for ArcGIS zu erstellen.

Artikel-ID:000019078

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden