Deutsch

How To: Erstellen von Konturlinien aus einer ASCII-Datei in ArcGIS Pro

Zusammenfassung

Eine in ASCII (.asc) formatierte Textdatei, die Rasterdaten repräsentiert, besteht aus Header-Informationen, wie der Anzahl an Spalten und Zeilen, den Koordinaten der linken unteren Ecke der linken unteren Zelle, der Zellgröße des Rasters etc., welche die Werte der einzelnen Zellen in der Datei beschreiben.

Eine ASCII-Datei kann nicht direkt in ArcGIS Pro geöffnet werden. Die Datei muss zunächst in ein Raster-Dataset konvertiert werden. Zum Erstellen von Konturlinien muss das Werkzeug "Konturlinien" verwendet werden.

Vorgehensweise

In den Anweisungen wird beschrieben, wie Konturlinien aus der ASCII-Datei in ArcGIS Pro erstellt werden.

  1. Verwenden Sie das Werkzeug 3D-ASCII in Feature-Class, um die XYZ-Datei in Punkt-Features zu konvertieren.
    1. Öffnen Sie ein neues leeres Projekt in ArcGIS Pro.
    2. Klicken Sie auf der Registerkarte Analyse auf das Symbol Werkzeuge in der Gruppe Geoverarbeitung, um den Bereich Geoverarbeitung zu aktivieren.
    3. Navigieren Sie zu Toolboxes > Conversion Tools > In Raster > ASCII in Raster.
    4. Wählen Sie im Abschnitt Parameter die ASCII-Datei als Eingabe-ASCII-Raster-Datei aus.
    5. Legen Sie einen Namen und einen Speicherort für das Ausgabe-Raster fest.
    6. Wählen Sie Integer oder Float als Ausgabedatentyp fest.
Hinweis:
"Integer" speichert nur ganze Werte bzw. Ganzzahlen. "Float" speichert nur Gleitkommawerte, d. h. Werte mit potenziellen Dezimalstellen
ASCII to Raster tool
  1. Klicken Sie auf Ausführen, um das Werkzeug auszuführen. Es wird ein Raster-Dataset erstellt.
A raster dataset is created
  1. Verwenden Sie das Werkzeug Konturlinien zum Erstellen von Konturlinien aus dem in Schritt 1 erstellten Raster-Dataset.
    1. Navigieren Sie in Toolboxes zu Spatial Analyst Tools > Oberfläche > Konturlinie.
    2. Wählen Sie im Abschnitt Parameter das in Schritt 1 erstellte Raster-Dataset als Eingabe-Raster aus.
    3. Legen Sie einen Namen und einen Speicherort für die Ausgabe-Polylinien-Features fest.
    4. Legen Sie den Parameter Konturlinienintervall mit einer beliebigen positiven Zahl für das gewünschte Intervall zwischen den Konturlinien fest.
Contour tool
  1. Klicken Sie auf Ausführen, um das Werkzeug auszuführen. Die Konturlinien mit dem angegebenen Intervall werden auf der Karte angezeigt.
The contour lines with the specified interval are displayed in the map

Referenzinformationen