Deutsch

How To: Importieren von Tabellen mit XY-Daten in ArcMap und Konvertieren der Daten in ein Shapefile mithilfe von ArcMap 10.0 oder früheren Versionen

Zusammenfassung

Hinweis: 
Die Informationen in diesem Artikel gelten nur für die ArcGIS-Versionen 10.0 und früher. Höhere Versionen von ArcGIS enthalten möglicherweise andere Funktionalitäten sowie andere Namen für Menüs, Befehle und Geoverarbeitungswerkzeuge, die sich auch an anderen Orten befinden können. Informationen zum Durchführen dieser Aktionen in ArcGIS 10.1 und höheren Versionen finden Sie unter: How To: Importieren von XY-Daten in ArcMap und Konvertieren der Daten in ein Shapefile oder eine Feature-Class unter ArcMap 10.1 oder höheren Versionen

In ArcMap (und ArcGIS Pro) können Daten im DMS-Format (Grad, Minuten, Sekunden) nicht gelesen werden. Diese müssen daher vor dem Importieren in Dezimalgrad (DD) konvertiert werden.

In den folgenden Schritten finden Sie Anweisungen, wie Sie XY-Daten in Dezimalgrad mit Microsoft Excel formatieren und diese Daten in ein Shapefile oder eine Geodatabase-Feature-Class in ArcMap konvertieren können.

ArcMap kann verschiedene Tabellenformate lesen, um Punktdaten als Ereignisdesign in ArcMap aufzunehmen.

Hinweis:
In Version 9.1 und früher kann ArcMap die folgenden Formate lesen: DBase III, DBase IV, PRN, TXT und CSV. Sofern vorhanden müssen zusätzliche Tabellenblätter aus diesen Formaten in Excel gelöscht werden.
Hinweis:
In Version 9.2 und höheren Versionen kann ArcMap die oben angegebenen Formate sowie XLS- und XLSX-Tabellen lesen. In den neueren Versionen von Excel werden das DBase III- und DBase IV-Dateiformat (.dbf) nicht mehr unterstützt.

Vorgehensweise

  1. Damit ArcMap die Daten in der Datei richtig liest, formatieren Sie die Spalten mit den Werten für den Längengrad (X oder Ostwert) und den Breitengrad (Y oder Nordwert) in Excel als ZAHL mit mindestens acht Dezimalstellen.

    In der Ausgabedatei sind Beschreibungen des Inhalts der einzelnen Spalten erforderlich. Beschriften Sie die Spalten mit ID, Längengrad, Breitengrad, Beschreibung usw.
Die folgende Grafik zeigt die Verteilung von positiven und negativen Werten für Koordinaten mit Längengrad (X) und Breitengrad (Y) weltweit.

[O-Image] Decimal degree coordinates and signs
  1. Wählen Sie nach der Formatierung der Datei alle Zellen in gefüllten Zeilen und Spalten in der Tabelle aus, und navigieren Sie zu Datei > Druckbereich > Druckbereich festlegen oder Seitenlayout > Druckbereich > Druckbereich festlegen.
    • In den neueren Versionen von Excel befinden sich die Optionen von Druckbereich auf der Registerkarte Seitenlayout.
  2. Navigieren Sie zu Datei > Speichern unter, und wählen Sie ein unterstütztes Format aus den in Excel verfügbaren Optionen aus. Klicken Sie auf Ja, wenn in Excel eine Warnung angezeigt wird, dass bestimmte Formatierungen in diesem Dateiformat nicht unterstützt werden.
  3. Beenden Sie Excel. Klicken Sie auf Nein, wenn Excel Sie zum Speichern der Änderungen auffordert.
Hinweis:
Wenn die Änderungen gespeichert werden, konvertiert Excel die Datei in eine XLS- oder XLSX-Arbeitsmappe, die nur in ArcMap mit Version 9.2 und neueren Versionen verwendet werden kann.
  1. Um ArcMap die Daten aus der DBF-, CSV-, TXT- oder PRN-Datei hinzuzufügen, navigieren Sie zu Werkzeuge > XY-Daten hinzufügen, und wählen Sie die Datei aus.
    • Klicken Sie in Version 10.x auf die Schaltfläche Daten hinzufügen.
  2. Klicken Sie mit der rechten Maustaste auf den Tabellennamen, und wählen Sie XY-Daten anzeigen aus.
Warnung:
In Version 10.0 wendet ArcMap das Koordinatensystem des Datenrahmens auf die XY-Daten an. Dieses Koordinatensystem ist für die Daten wahrscheinlich falsch.
Klicken Sie auf die Schaltfläche Bearbeiten, um das Dialogfeld Eigenschaften des Raumbezugs zu öffnen. Klicken Sie auf die Schaltfläche Auswählen, um ein Koordinatensystem für die Daten auszuwählen.
Hinweis:
Wenn eine Warnmeldung bezüglich des fehlenden Objekt-ID-Feldes angezeigt wird, können Sie sie einfach ignorieren und auf "OK" klicken. 
[O-Image]

Beispielsweise werden GPS-Daten meistens in Dezimalgrad oder als Breitengrad/Längengrad und damit als ein geographisches Koordinatensystem erfasst. Öffnen Sie das entsprechende Verzeichnis. Meist werden GPS-Daten mit dem WGS-1984-Datum erfasst. Öffnen Sie also den Ordner World, und wählen Sie WGS_1984.prj aus.

Wenn die Daten mit einem anderen Datum erfasst wurden, klicken Sie im Abschnitt "Referenzinformationen" auf den Link Geographic Coordinate Systems and Areas of Use, um das geeignete Datum zu finden.

  1. Klicken Sie nach der Definition der Projektion im Dialogfeld Eigenschaften des Raumbezugs auf Hinzufügen, Übernehmen und OK. Klicken Sie im Dialogfeld XY-Daten hinzufügen auf OK. Die Punkte werden als Ereignisdesign in ArcMap dargestellt. Überprüfen Sie, ob das Ereignisdesign auf andere Daten in ArcMap abgestimmt ist.
Hinweis:
Wenn die Daten nicht auf die Referenzdaten abgestimmt sind, lesen Sie den folgenden Knowledge Base-Artikel: How To: Identifizieren des Raumbezugs, der Projektion oder des Koordinatensystems von Daten.
  1. Um das Ereignisdesign in ein Shapefile oder eine Geodatabase-Feature-Class zu konvertieren, klicken Sie mit der rechten Maustaste auf den Dateinamen, und wählen Sie Daten > Daten exportieren aus. Die Punkte können in eine Geodatabase-Feature-Class oder ein Shapefile exportiert werden.
  2. Bei diesem Vorgang können die Daten auch erneut auf das Koordinatensystem des ArcMap-Datenrahmens projiziert werden. Navigieren Sie über Ansicht > Eigenschaften: Datenrahmen zur Registerkarte Koordinatensystem, und wählen Sie die gewünschte Ausgabeprojektion für die Ausgabedaten aus. Um die Projektion während des Exports zu erstellen, klicken Sie mit der rechten Maustaste auf das Design Ereignisse, wählen Sie Daten > Daten exportieren aus, und ändern Sie das Optionsfeld so, dass das Koordinatensystem des Datenrahmens exportiert wird. Die Ausgabedaten befinden sich im ausgewählten Ausgabe-Koordinatensystem.
  3. Gehen Sie wie folgt vor, um den Ereignis-Layer mit dem Werkzeug Projizieren auf ein projiziertes Koordinatensystem zu projizieren:
    1. Navigieren Sie in ArcMap zu ArcCatalog > Toolboxes > System-Toolboxes > Data Management Tools > Projektionen und Transformationen > Projizieren.
    2. Geben Sie im Dialogfeld des Werkzeugs Projizieren die erforderlichen Parameter an:
      • Eingabe-Dataset oder -Feature-Class: Die Feature-Class, der Feature-Layer oder das Feature-Dataset, die/der/das projiziert werden soll.
      • Eingabe-Koordinatensystem (optional): Das Koordinatensystem der Eingabe-Feature-Class oder des Eingabe-Datasets.
      • Ausgabe-Koordinatensystem: Das Koordinatensystem, in welches die Eingabedaten projiziert werden.
      • Geographische Transformation (optional): Zum Konvertieren von Daten zwischen geographischen Koordinatensystemen oder Daten.
    3. Klicken Sie auf OK.
Hinweis:
Wenn ArcMap darauf hinweist, dass das geographische Koordinatensystem nicht mit anderen Daten in der Karte übereinstimmt, navigieren Sie über "Ansicht" und "Eigenschaften: Datenrahmen" zur Registerkarte "Koordinatensystem", und klicken Sie auf die Schaltfläche "Transformationen". Dort können Sie überprüfen, ob die richtige Datumstransformation für den Bereich verwendet wird, in dem sich die Daten befinden.
Hinweis:
Eine Liste der geographischen (Datums-) Transformationen und deren Einsatzbereiche finden Sie im folgenden Artikel: How To: Auswählen der richtigen geographischen (Datums-)Transformation beim Projizieren zwischen Daten. Laden Sie im Abschnitt "Referenzinformationen" dieses Artikels die Liste der Transformationen für die auf dem Computer installierte Version von ArcGIS Desktop herunter.

Referenzinformationen