PROBLEM

Lizenzen werden nach dem Beenden einer ArcGIS-Sitzung nicht freigegeben

Last Published: November 24, 2020

Beschreibung

Die Lizenz wird nach dem Beenden einer ArcGIS-Sitzung nicht in den Pool verfügbarer Lizenzen zurückgegeben.

Hinweis: Dieser Artikel gilt für die ArcGIS-Versionen 8.x und 9.x. Höhere Versionen von ArcGIS enthalten möglicherweise andere Funktionalität sowie andere Namen für Menüs, Befehle und Geoverarbeitungswerkzeuge, die sich auch an anderen Orten befinden können.
Hinweis: Die Informationen in diesem Artikel gelten für die eingestellten Produkte ARC/INFO und ArcInfo Workstation.

Ursache

Dieses Problem ist in der Regel auf Inkonsistenzen oder Fehler in der Netzwerkkommunikation zurückzuführen. Auch Geräte im Netzwerk wie Switches, Router oder Firewalls, die die Kommunikation zwischen ArcGIS und dem Lizenzmanager stören, können dieses Problem verursachen.

Lösung oder Problemumgehung

Der Lizenzmanager initiiert zwei TCP-Verbindungen, um eine Lizenz ein- bzw. auszuchecken. Eine ist standardmäßig auf TCP-Port 27005 (8.x und früher) oder 27004 (9.0 und höher) und die andere auf einen nach Zufallsprinzip gewählten TCP-Port festgelegt. Dieser dynamische/nach Zufallsprinzip gewählte zweite Port kann von Routern, Switches oder Firewalls im Netzwerk zwischen dem Lizenzserver und dem Client blockiert werden. Beheben Sie dieses Problem, indem Sie für den Lizenzmanager die Ausführung auf einem statischen Port festlegen und anschließend diesen Port auf allen störenden Netzwerkgeräten öffnen.

  1. Legen Sie in den Lizenzdateien den statischen zweiten Port mit einem Text-Editor fest. Diese Dateien befinden sich für Windows und ArcGIS 8.x im Verzeichnis "C:\Programme\ESRI\License" und für Windows und ArcGIS 9.x im Verzeichnis "C:\Programme\ESRI\License\Arcgis9x". Für UNIX befinden sie sich im Verzeichnis "$ARCHOME/sysgen". Fügen Sie wie im Folgenden dargestellt in allen LIC- und DAT-Dateien in der VENDOR-Zeile "PORT=####" hinzu:
Code: VENDOR ESRI PORT=####

Für Benutzer von ArcGIS 9.x sieht das wie folgt aus:

Code: VENDOR ARCGIS PORT=####
Hinweis: Bei Windows-Lizenzmanagern müssen die LIC-Dateien alle identisch bearbeitet werden.
  1. Speichern Sie die Datei.
  2. Beenden Sie den Lizenzmanager.
    Informationen zum Verfahren unter Windows finden Sie unter How To: Beenden von Esri License Manager unter Verwendung von LMTOOLS.
    Informationen zum Verfahren unter UNIX finden Sie unter How To: Stop or start the Esri License Manager on UNIX.
  3. Starten Sie den Lizenzmanager:
    Informationen zum Verfahren unter Windows finden Sie im Knowledge Base-Artikel How To: Starten von Esri License Manager unter Verwendung von LMTOOLS.
    Informationen zum Verfahren unter UNIX finden Sie unter How To: Stop or start the Esri License Manager on UNIX.
  4. Stellen Sie sicher, dass alle Geräte im Netzwerk zwischen dem Client und dem Server so eingestellt sind, dass der in Schritt 1 angegebene Port akzeptiert wird.
Hinweis: Wenden Sie sich an Ihren System- oder Netzwerkadministrator.

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