HOW TO

Das Löschen einer Anwendung in Portal for ArcGIS ist nicht möglich

Last Published: May 16, 2024

Beschreibung

Wenn Sie in Portal for ArcGIS versuchen, eine Anwendung zu erstellen oder eine Kopie einer vorhandenen Anwendung zu erstellen, bleibt der Vorgang auf unbestimmte Zeit hängen. In einigen Fällen wird die Anwendung trotz des anhaltenden Prozesses weiterhin erstellt, auch wenn der Prozess beendet wird. Die daraus resultierende Anwendung kann jedoch nicht mit den Anmeldeinformationen des Portal-Administrators auf der Portal-Startseite gelöscht werden.

Ursache

Bestimmte Portal-Indizes sind beschädigt, wodurch verhindert wird, dass die Indizes mit den neuesten Änderungen synchronisiert werden.

Lösung oder Problemumgehung

  1. Löschen Sie die erstellte Anwendung auf der Seite "Portal Sharing Rest".
    1. Navigieren Sie zur Seite "Portal Sharing Rest", und melden Sie sich mit den Anmeldeinformationen des Administrators unter Verwendung der folgenden URL an:
https://<portal_domain>.com/<portal_webadaptor_name>/sharing/rest
  1. Navigieren Sie zu Related Resources > User Content.
  2. Suchen Sie das Element, das gelöscht werden soll, und wählen Sie es aus.
  3. Scrollen Sie auf der Seite User Item nach unten, und überprüfen Sie, ob der Parameter Protected auf "false" festgelegt ist.
Note:
If the Protected parameter is set to true, navigate to Supported Operations and click Unprotect. On the Unprotect Item page, select an appropriate format and click Unprotect Item.
  1. Klicken Sie auf Can Delete Item.
  2. Klicken Sie auf der Seite Can Delete Item auf Can Delete Item?, und überprüfen Sie, ob "true" angezeigt wird.
  3. Navigieren Sie zurück zur Seite User Item, und klicken Sie auf Delete Item.
  4. Aktivieren Sie auf der Seite Delete Item das Kontrollkästchen Force deletion?, wählen Sie ein geeignetes Format aus, und klicken Sie auf Delete Item.
  1. Führen Sie eine vollständige Neuindizierung über Portal Admin durch.
    1. Navigieren Sie als Administrator unter Verwendung der folgenden URL zum Portal-Administratorverzeichnis:
https://<machine_name>.<domain_name>.com/webadaptor/portaladmin
  1. Navigieren Sie zu System > Indexer > Reindex.
  2. Wählen Sie für Modus die Option Full aus der Dropdown-Liste aus.
  3. Wählen Sie unter Format ein Antwortformat aus der Dropdown-Liste aus.
  4. Klicken Sie auf Reindex.

Artikel-ID: 000032127

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln