PROBLEM

Es konnte keine Verbindung zum ArcGIS-Lizenzmanager hergestellt werden

Last Published: September 26, 2022

Beschreibung

Bei dem Versuch, ein ArcGIS-Produkt mit einer Concurrent-Use-Lizenz zu verwenden, können Benutzer keine Verbindung zum ArcGIS-Lizenzmanager herstellen, sodass ArcGIS-Produkte wie ArcMap, ArcGIS Pro und ArcCatalog nicht verwendet werden können. Beim Starten dieser Produkte kann es passieren, dass die Software nicht mehr reagiert oder die Produkte nicht geladen werden.

Ursache

Es gibt mehrere Gründe, weshalb ein Benutzer möglicherweise nicht in der Lage ist, eine Verbindung zum ArcGIS-Lizenzmanager herzustellen. Einige dieser Gründe sind nachfolgend aufgeführt:

  • Die Version von ArcGIS License Manager und die Version der Client-Software sind nicht kompatibel.
  • Der ArcGIS-Lizenzmanager wird nicht ausgeführt.
  • Der ArcGIS-Lizenzmanager oder die FlexNET-Services werden nicht ausgeführt.
  • Bei der Verbindung wurde für ArcGIS License Manager eine falsche IP-Adresse verwendet.
  • Zum Herstellen einer Verbindung mit ArcGIS License Manager wurden falsche Ports verwendet.
  • Eine Firewall ist nicht für das Zulassen von Verbindungen zum ArcGIS-Lizenzmanager konfiguriert.

Lösung oder Problemumgehung

Es gibt sechs Lösungen, die unten beschrieben werden, um Probleme mit Verbindungen zum ArcGIS-Lizenzmanager zu beheben und zu lösen. Folgen Sie den Lösungswegen in der beschriebenen Reihenfolge, und versuchen Sie nach jeder Lösung, eine Verbindung zum ArcGIS-Lizenzmanager herzustellen.

Überprüfen der Versionskompatibilität von ArcGIS License Manager und Client-Software

ArcGIS License Manager ist mit der Client-Software derselben Version oder einer höheren Version kompatibel. Weitere Informationen dazu, welche Client-Versionen mit der jeweiligen Version von ArcGIS License Manager kompatibel ist, finden Sie unter Leitfaden zu License Manager: Unterstützte Softwareprodukte.

Überprüfen, ob der ArcGIS-Lizenzmanager ausgeführt wird

Ein Client-Computer kann keine Verbindung zum ArcGIS-Lizenzmanager herstellen, wenn dieser nicht ausgeführt wird.

  1. Navigieren Sie zu Start > Programme > ArcGIS > License Manager, und starten Sie den License Server Administrator auf dem Hostcomputer.
  2. Überprüfen Sie, ob der Lizenzserverstatus mit WIRD AUSGEFÜHRT angegeben ist.
ArcGIS License Server Administrator-Statusseite
  1. Wenn der Lizenzserverstatus mit WIRD NICHT AUSGEFÜHRT angegeben ist, klicken Sie auf Start > Lizenzen neu lesen.

Neu starten des ArcGIS-Lizenzmanagers und der FlexNET-Lizenzierungsservices

Die Ausführung des ArcGIS-Lizenzmanagers wird möglicherweise aufgrund bestimmter Einstellungen in den Windows-Services beendet. Durch die Änderung dieser Einstellungen wird sichergestellt, dass der ArcGIS-Lizenzmanager automatisch ausgeführt wird.

  1. Führen Sie services.msc aus.
  2. Suchen Sie in der Liste nach ArcGIS-Lizenzmanager. Klicken Sie mit der rechten Maustaste auf ArcGIS-Lizenzmanager, und wählen Sie Eigenschaften aus.
Seite
  1. Klicken Sie auf den Dropdown-Pfeil Starttyp, und wählen Sie Automatisch aus. Klicken Sie auf Start > OK.
ArcGIS License Manager-Eigenschaftenseite
  1. Suchen Sie in der Liste nach FlexNet-Lizenzierungsservice. Klicken Sie mit der rechten Maustaste auf FlexNet-Lizenzierungsservice, und wählen Sie Eigenschaften aus.
  2. Klicken Sie auf den Dropdown-Pfeil Starttyp, und wählen Sie Automatisch aus. Klicken Sie auf Start > OK.
  3. Starten Sie License Server Administrator. Überprüfen Sie den Lizenzserverstatus, und stellen Sie sicher, dass er WIRD AUSGEFÜHRT lautet.
  4. Stellen Sie über ArcGIS Administrator eine Verbindung zum ArcGIS-Lizenzmanager her.

Herstellen einer Verbindung zum ArcGIS-Lizenzmanager über eine IP-Adresse

Durch das Herstellen einer Verbindung zum ArcGIS-Lizenzmanager über eine IP-Adresse wird sichergestellt, dass ArcGIS Administrator auf den richtigen ArcGIS-Lizenzmanager zugreift.

  1. Öffnen Sie auf dem Hostcomputer die Eingabeaufforderung.
  2. Geben Sie ipconfig ein, und drücken Sie die Eingabetaste. Notieren Sie sich die IPV4-Adresse.
  3. Starten Sie ArcGIS Administrator auf dem Client-Computer.
  4. Klicken Sie im linken Fensterbereich von ArcGIS Administrator auf Desktop. Klicken Sie im rechten Bereich auf Ändern.
  5. Geben Sie die IP-Adresse des ArcGIS-Lizenzmanagers ein. Klicken Sie auf OK.

Herstellen einer Verbindung zum ArcGIS-Lizenzmanager über einen Port

Der ArcGIS-Lizenzmanager kann an den Ports 27000 bis 27009 ausgeführt werden. Die Verbindung kann durch andere Programme beeinträchtigt werden, wenn sie denselben Port verwenden, sodass ArcGIS Administrator dann keine Verbindung zum ArcGIS-Lizenzmanager herstellen kann. Um dies zu verhindern, stellen Sie die Verbindung zum ArcGIS-Lizenzmanager über einen bestimmten Port her.

  1. Starten Sie ArcGIS Administrator auf dem Client-Computer.
  2. Klicken Sie im linken Fensterbereich von ArcGIS Administrator auf Desktop. Klicken Sie im rechten Bereich auf Ändern.
  3. Geben Sie den Hostnamen und die Portnummer im folgenden Format ein: "port@hostname". Klicken Sie auf OK.
Abbildung des Dialogfeldes

Ändern der Datei "services.txt"

Standardmäßig ist in der Datei "service.txt" kein bestimmter Port für die Verwendung durch den ArcGIS-Lizenzmanager angegeben. Durch die Bearbeitung dieser Datei wird der ArcGIS-Lizenzmanager einem bestimmten, nicht verwendeten Port zugewiesen.

  1. Navigieren Sie zum folgenden Verzeichnis, und öffnen Sie "service.txt" auf dem Hostcomputer.
C:\Programme\ArcGIS\License10.x\bin
  1. Die Datei hat standardmäßig den unten gezeigten Inhalt:
SERVER this_host ANY VENDOR ARCGIS FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
  1. Bearbeiten Sie den Inhalt der Datei wie unten gezeigt:
SERVER this_host ANY 27000 VENDOR ARCGIS port=27004 FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
Hinweis: Für VENDOR ARCGIS PORT kann ein beliebiger Wert zwischen 27000 und 27009 verwendet werden.
  1. Speichern Sie die Datei "service.txt".
  2. Stellen Sie über ArcGIS Administrator eine Verbindung zum ArcGIS-Lizenzmanager her.

Konfigurieren der Firewall

Firewall-Konfigurationen können dazu führen, dass der ArcGIS-Lizenzmanager keine eingehenden und ausgehenden Verbindungen herstellen kann. Die Firewall muss so konfiguriert sein, dass der ArcGIS-Lizenzmanager darüber arbeiten kann.

  1. Navigieren Sie zu Systemsteuerung > Windows-Firewall > Erweiterte Einstellungen.
  2. Klicken Sie im linken Bereich auf Eingehende Regeln.
Abbildung des Fensters
  1. Klicken Sie im rechten Bereich auf Neue Regel. Daraufhin wird der Assistent für neue eingehende Regel ausgeführt.
  2. Wählen Sie Programm > Weiter aus.
Abbildung der Auswahl des Regeltyps im Assistenten für neue eingehende Regeln
  1. Wählen Sie Dieser Programmpfad aus. Navigieren Sie zum folgenden Verzeichnis, und wählen Sie lmgrd.exe >Öffnen > Weiter aus:
C:\Programme(x86)\ArcGIS\License10.x\bin
Abbildung der Programmauswahl im Assistenten für neue eingehende Regeln
  1. Wählen Sie Verbindung zulassen > Weiter aus.
Abbildung der Aktionsauswahl im Assistenten für neue eingehende Regeln
  1. Aktivieren Sie die Kontrollkästchen aller verfügbaren Optionen, und klicken Sie auf Weiter.
Abbildung der Profilauswahl im Assistenten für neue eingehende Regeln
  1. Geben Sie einen Namen für die Regel ein (zum Beispiel "ArcGIS-Lizenzmanager"), und klicken Sie auf Fertig stellen.
Abbildung der Auswahl des Namens im Assistenten für neue eingehende Regeln
  1. Wiederholen Sie diese Schritte für die folgenden Dateien: ARCGIS.exe und LSAdmin.exe. Beide Dateien befinden an dem in Schritt 5 angegebenen Speicherort.
  2. Wiederholen Sie das unter "Konfigurieren der Firewall" beschriebene Verfahren für Ausgehende Regeln.

Artikel-ID: 000019755

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