PROBLEM

Das Widget "Suche" gibt keine Ergebnisse aus dem gehosteten Feature-Layer in ArcGIS Web AppBuilder zurück

Last Published: August 17, 2021

Beschreibung

Mit dem Widget "Suche" können Benutzer Positionen finden und auf der Karte nach Features suchen, indem sie Geokodierungsservices oder Feature-Layer innerhalb der Karte verwenden. Mitunter werden bei der Suche nach einer Adresse mithilfe der Suchfunktion keine Ergebnisse zurückgegeben, wenn die Suchquelle aus einem gehosteten Feature-Layer stammt.

Die folgende Abbildung zeigt ein Beispiel, bei dem keine Ergebnisse zurückgegeben werden, wenn der Benutzer mit der Suchfunktion nach einer Adresse sucht.

Nach Eingabe von Adressen im Suchfeld in ArcGIS Web AppBuilder werden keine Ergebnisse zurückgegeben.

Ursache

Das Problem tritt auf, wenn der Name des ursprünglichen verwendeten Feature-Layers geändert wurde. Daher kann die Service-URL des Layers nicht gefunden werden.

Lösung oder Problemumgehung

Führen Sie die folgenden Schritte aus, um die Suchquelle im Fenster Konfigurieren Suche neu zu konfigurieren. Entfernen Sie den ursprünglichen gehosteten Feature-Layer aus der Suchquelle, und fügen Sie den neuen gehosteten Feature-Layer wieder hinzu.

  1. Klicken Sie in ArcGIS Web AppBuilder auf die Registerkarte Widget.
  2. Klicken Sie auf das Symbol Dieses Widget konfigurieren des Widgets Suche.
Klicken Sie im Widget
  1. Klicken Sie im Fenster Konfigurieren Suche unter Einstellungen der Suchquellen auf das Symbol Löschen für den ursprünglichen gehosteten Feature-Layer.
Löschen Sie den ursprünglichen Feature-Layer aus der Liste
  1. Klicken Sie auf Suchquelle hinzufügen, um den neuen gehosteten Feature-Layer hinzuzufügen. Klicken Sie auf OK.
  2. Klicken Sie auf der Registerkarte Widget auf Speichern, um die Änderungen zu speichern.

Die folgende Abbildung zeigt die Suchergebnisse, nachdem die Suchquelle mit dem neuen gehosteten Feature-Layer neu konfiguriert wurde.

Nach Eingabe von Adressen im Suchfeld in ArcGIS Web AppBuilder werden Ergebnisse zurückgegeben.

Artikel-ID: 000026112

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln