PROBLEM

Das Veröffentlichen von Surveys endet beim Erstellen eines Formularelements in ArcGIS Survey123 Connect

Last Published: October 28, 2024

Beschreibung

Beim Veröffentlichen eines Survey in ArcGIS Survey123 Connect in ArcGIS Online oder im ArcGIS Enterprise-Portal wird der Vorgang geladen, jedoch nicht abgeschlossen; er wird bei "Formularelement erstellen" angehalten, wie in der folgenden Abbildung dargestellt.

Die Veröffentlichungsseite in ArcGIS Survey123 Connect.

Ursache

  • Das XLSForm mit demselben Namen wird in mehreren Surveys verwendet. Die Verwendung desselben XLSForm-Namens in mehreren Surveys führt zu Problemen, da jeder Survey eine eindeutige Formular-ID aufweisen muss.
  • Das XLSForm enthält große Dateien im Medienordner. Eine große Anzahl von Bilddateien, Audiodateien oder großen benutzerdefinierten Grundkartendateien führt zu Problemen beim Veröffentlichen.

Lösung oder Problemumgehung

Speichern Sie das XLSForm unter einem anderen Namen, bevor Sie einen neuen Survey erstellen.

  1. Navigieren Sie auf dem lokalen Computer zum Survey-Ordner unter:
C:\Users\<username\ArcGIS\My Survey Designs\<survey_title>
  1. Benennen Sie das XLSForm des Survey um, und speichern Sie es. Stellen Sie sicher, dass in ArcGIS Online oder im ArcGIS Enterprise-Portal keine Surveys oder Feature-Layer mit demselben Namen vorhanden sind.
  2. Erstellen Sie einen neuen Survey mit dem XLSForm.
    1. Klicken Sie in ArcGIS Survey123 Connect auf Neuer Survey.
    2. Melden Sie sich bei der ArcGIS-Organisation an.
    3. Geben Sie für Titel einen Titel für den neuen Survey an.
    4. Wählen Sie für Neues Survey-Formular erstellen die Option Datei aus.
    5. Klicken Sie für XLSForm-Datei auf Auswählen, suchen Sie nach dem in Schritt 1 gespeicherten XLSForm, und wählen Sie es aus.
    6. Klicken Sie auf Survey erstellen.
  3. Klicken Sie auf die Schaltfläche Veröffentlichen, um den neuen Survey zu veröffentlichen.

Entfernen Sie die große Datei aus dem Medienordner des Survey.

  1. Öffnen Sie den Survey in ArcGIS Survey123 Connect, und klicken Sie auf die Registerkarte Medien.
  2. Klicken Sie auf Medienordner öffnen, navigieren Sie zu dem Element, und löschen Sie das Element.

Alternativ können Sie das Element direkt aus dem Medienordner auf dem lokalen Computer löschen, der sich im folgenden Verzeichnis befindet:

C:\Users\<username>\ArcGIS\My Survey Designs\<survey_title>\media

Artikel-ID: 000032311

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln