ERROR

Umgebung konnte nicht erstellt werden

Last Published: March 25, 2021

Fehlermeldung

ArcGIS Pro umfasst den Python-Paketmanager, mit dem Python-Pakete direkt in der aktuellen Umgebung bearbeitet werden können. Der Paketmanager ermöglicht das Klonen, Aktivieren und Entfernen einer Python-Umgebung in ArcGIS Pro. In einigen Fällen kommt es nach der Aktualisierung der ArcGIS Pro-Version zu einem Fehler, wenn die standardmäßige Python-Projektumgebung geklont wird. Der Vorgang kann nicht abgeschlossen werden, und es wird folgende Fehlermeldung zurückgegeben:

Error: Umgebung konnte nicht erstellt werden
Das Klonen der standardmäßigen Python-Umgebung schlägt mit der folgenden Fehlermeldung fehl: Umgebung konnte nicht erstellt werden.

Ursache

Die ArcGIS Pro-Aktualisierung wurde bei Verwendung der Option "Softwareaktualisierung" in ArcGIS Pro nicht abgeschlossen.

Lösung oder Problemumgehung

Führen Sie den nachstehenden Workflow aus, um das Problem zu beheben.

Reparieren der ArcGIS Pro-Installation und Klonen der Standardumgebung "arcgispro-py3"
  1. Navigieren Sie auf dem Computer zu Systemsteuerung.
  2. Klicken Sie auf Programme und Funktionen, und wählen Sie Programme deinstallieren aus.
  3. Führen Sie in der Liste der Programme einen Bildlauf zu ArcGIS Pro durch, und klicken Sie mit der rechten Maustaste auf ArcGIS Pro.
  4. Klicken Sie auf Deinstallieren, um das Fenster Deinstallieren zu öffnen.
  5. Wählen Sie Reparieren aus, und klicken Sie auf Weiter.
Klick auf
  1. Klicken Sie auf Fertig stellen.
  2. Starten Sie ArcGIS Pro neu.
  3. Navigieren Sie zu Einstellungen Das Symbol  > Python.
  4. Klicken Sie auf der Seite Python-Paketmanager auf Umgebungen verwalten.
Klick auf die Option
  1. Erstellen Sie einen Klon der Standardumgebung "arcgispro-py3". Eine Anleitung hierzu finden Sie unter ArcGIS Pro: Create an environment.
Hinweis: Wenn das Klonen der standardmäßigen Projektumgebung nach der Reparatur fehlschlägt und nicht abgeschlossen werden kann, befolgen Sie den unten beschriebenen Workaround.
Deinstallation und Neuinstallation von ArcGIS Pro sowie Klonen der Standardumgebung "arcgispro-py3"
  1. Deinstallieren Sie ArcGIS Pro. Eine Anleitung hierzu finden Sie unter ArcGIS Pro: Deinstallieren von ArcGIS Pro.
  2. Laden Sie ArcGIS Pro von My Esri herunter.
Hinweis: Weitere Informationen zu den Berechtigungen, die für den Zugriff auf Downloads in My Esri erforderlich sind, finden Sie unter How To: Herunterladen und Installieren von Esri Software von My Esri.
  1. Installieren Sie ArcGIS Pro. Eine Anleitung hierzu finden Sie unter ArcGIS Pro: Installieren von ArcGIS Pro und optionalen Komponenten.
  2. Erstellen Sie einen Klon der Standardumgebung "arcgispro-py3". Eine Anleitung hierzu finden Sie unter ArcGIS Pro: Create an environment.

Artikel-ID: 000024977

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln