PROBLEM

Unable to create or delete ArcGIS Insights workbooks and pages from Portal for ArcGIS

Last Published: January 6, 2022

Description

Attempts to create or delete ArcGIS Insights workbooks and pages from Portal for ArcGIS fail, and may return the following error message in the portal logs:

Error:   
Servlet execution threw an exception

Cause

ArcGIS Insights is not installed on the ArcGIS Server or Portal for ArcGIS machine.

Solution or Workaround

Install ArcGIS Insights on the ArcGIS Server or Portal for ArcGIS machine. Refer to ArcGIS Insights: Install Insights in ArcGIS Enterprise for the steps to do so.

Note:
If the ArcGIS Insights workbooks and pages are still unable to be deleted from Portal for ArcGIS, navigate to C:\arcgisportal\content\items and delete the desired items. Refer to Error: Unable to delete item for more information on deleting detached items. Perform a full reindex in Portal for ArcGIS to ensure the items are deleted.

Article ID:000027037

Software:
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Insights 3 3
  • ArcGIS Insights 3 4

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