ERROR

ArcGIS Pro failed to connect to the License Manager for your Licensing Portal

Last Published: June 18, 2021

Error Message

When attempting to log in to ArcGIS Pro with an ArcGIS Enterprise Named User license, the login fails, and returns the following error message:

Error:   
ArcGIS Pro failed to connect to the License Manager for your Licensing Portal.

Please contact your organization's License Administrator to ensure that your ArcGIS License Manager is running and accessible.
The error message is returned when attempting to log in with an ArcGIS Enterprise Named User license

Cause

The hostname and port number for ArcGIS License Manager are not defined in Portal for ArcGIS. This does not allow Portal for ArcGIS to communicate with ArcGIS License Manager, and prevents it from validating all Named User licenses. Refer to ArcGIS Pro: Named User licensing in ArcGIS Enterprise for more information on how ArcGIS Enterprise Named User licenses work.

Solution or Workaround

To resolve the issue, perform the following workaround.

  1. Navigate to Portal Administrator Directory.
  2. Navigate to Home > License > Update License manager.
  3. Enter the hostname and port number for ArcGIS License Manager in the License Manager Info (in JSON format) text box.
Enter the hostname and the port number for the license manager in the 'License Manager Info (in JSON format)' text box
  1. Click Update.

Article ID:000025759

Software:
  • Portal for ArcGIS
  • ArcGIS Pro 2 8 x
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

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