ERROR

Error 1606: Could not access the network location

Last Published: April 5, 2022

Error Message

When attempting to add, remove, or change the installation of ArcGIS products, the following error message may return:

Error:   
Error 1606: Could not access the network location
Note:
There are many situations under which Error 1606 may be encountered. If a this error is returned, the best resource to find out why and to help remedy the issue is to provide a Windows Installer log file and analyze it.

Cause

This issue may occur if there is an incorrect setting in one of the registry keys related to Shell Folders.

Solution or Workaround

Warning:
The instructions below include making changes to essential parts of your operating system. Esri recommends backing up your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

Esri cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.

Verify that the values that correspond to user Shell Folders are set correctly and have a valid value.

  1. Navigate to Start > Run, type regedit.exe, and click OK.
  2. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders.
  3. In the details (right-hand) pane of the Registry Editor, verify that the values are the same as the values in the following table. If each value matches the table, go to step 7.
Windows XP and Windows Server 2003
Value Name     Value Data
==============================
AppData        %USERPROFILE%\Application Data 
Cache          %USERPROFILE%\Local Settings\Temporary Internet Files 
Cookies        %USERPROFILE%\Cookies 
Desktop        %USERPROFILE%\Desktop 
Favorites      %USERPROFILE%\Favorites 
History        %USERPROFILE%\Local Settings\History 
LocalAppData   %USERPROFILE%\Local Settings\Application Data 
Local Settings %USERPROFILE%\Local Settings 
My Pictures    %USERPROFILE%\My Documents\My Pictures 
NetHood        %USERPROFILE%\NetHood 
Personal       %USERPROFILE%\My Documents 
PrintHood      %USERPROFILE%\PrintHood 
Programs       %USERPROFILE%\Start Menu\Programs 
Recent         %USERPROFILE%\Recent 
SendTo         %USERPROFILE%\SendTo 
Start Menu     %USERPROFILE%\Start Menu 
Startup        %USERPROFILE%\Start Menu\programs\Startup 
Templates      %USERPROFILE%\Templates
Windows Vista, Windows 7, Windows Server 2008 and Windows 10
Value Name     Value Data
==============================
{374DE290-123F-
4565-9164-
39C4925E467B}  %USERPROFILE%\Downloads
AppData        %USERPROFILE%\AppData\Roaming 
Cache          %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files 
Cookies        %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Cookies 
Desktop        %USERPROFILE%\Desktop 
Favorites      %USERPROFILE%\Favorites 
History        %USERPROFILE%\AppData\Local\Microsoft\Windows\History 
LocalAppData   %USERPROFILE%\AppData\Local 
My Pictures    %USERPROFILE%\Pictures
My Music       %USERPROFILE%\Music
My Video       %USERPROFILE%\Videos
NetHood        %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Network Shortcuts
Personal       %USERPROFILE%\Documents 
PrintHood      %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Printer Shortcuts 
Programs       %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs 
Recent         %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Recent 
SendTo         %USERPROFILE%\AppData\Roaming\Microsoft\Windows\SendTo 
Start Menu     %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu 
Startup        %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup 
Templates      %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Templates
  1. If any Name or Data value does not match the table in step 3, right-click the Value name, and click Delete.
  2. On the left side, right-click User Shell Folders, point to New, click Expandable String Value, type the Name value that was just deleted from the table in step 3, and press Enter to create the variable.
  3. Right-click the value created in step 5, click Modify, type the value in the Value data field for the Value name, and click OK.
Note:
Repeat steps 5 and 6 for any of the values that were deleted.
  1. Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders.
  2. On the right side, verify that the values are the same as the values in the following table. If each value matches the table, go to step 12.

Windows XP and Windows Server 2003

Value name        Value data 
=============================
Common AppData    %ALLUSERSPROFILE%\Application Data 
Common Desktop    %ALLUSERSPROFILE%\Desktop 
Common Documents  %ALLUSERSPROFILE%\Documents 
Common Favorites  %ALLUSERSPROFILE%\Favorites 
Common Programs   %ALLUSERSPROFILE%\Start Menu\Programs 
Common Start Menu %ALLUSERSPROFILE%\Start menu 
Common Startup    %ALLUSERSPROFILE%\Start Menu\Programs\Startup 
Common templates  %ALLUSERSPROFILE%\Templates

Windows Vista, Windows 7, Windows Server 2008 and Windows 10

Value name        Value data 
=============================
{3D644C9B-1FB8-
4f30-9B45-
F670235F79C0}     %PUBLIC%\Downloads
Common AppData    %ProgramData% 
Common Desktop    %PUBLIC%\Desktop 
Common Documents  %PUBLIC%\Documents 
Common Programs   %ProgramData%\Microsoft\Windows\Start Menu\Programs 
Common Start Menu %ProgramData%\Microsoft\Windows\Start Menu 
Common Startup    %ProgramData%\Microsoft\Windows\Start Menu\Programs\Startup 
Common templates  %ProgramData%\Microsoft\Windows\Templates
CommonMusic       %PUBLIC%\Music
CommonPictures    %PUBLIC%\Pictures
CommonVideo       %PUBLIC%\Videos
  1. If any Name or Data does not match the table in step 3, right-click the Value name, and click Delete.
  2. On the left hand side, right-click User Shell Folders, point to New, click Expandable String Value, type the Name value that was removed from the table in step 3, and press Enter.
  3. Right-click the value created in step 5, click Modify, type the value in the Value data field for the Value name, and click OK.
Note:
Again repeat steps 10-11 for each of the values that were removed.
  1. Close the Registry Editor, and restart the computer.
Note:
Alternatively, use the Microsoft Fix-It utility to automatically clean up the issues and uninstall the program. Refer to Microsoft Support: Fix problems that block programs from being installed or removed for more information.

Article ID:000007987

Software:
  • ArcMap

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic