English

Problem: Missing toolbar

Description

A toolbar that that was available at a previous point in an ArcMap session may not be visible when working on the same mxd.

Cause

The toolbar my be turned off, hidden, or there are errors with the mxd.

Solution or Workaround

  1. Open the mxd that has the missing toolbar. Make sure it is the only program open.
  2. On the Customize menu, select Customize Mode. Click the Toolbars tab and check the missing toolbar to turn it on and off.
    Customize dialog box

    [O-Image]
    Note:
    While toggling the tool's visibility on/off, make sure to look for the toolbar on the display. Begin by checking the standard toolbar and then review the remainder of the display.

  3. If the toolbar does not appear after toggling it on/off, start a new blank map document to see if it displays in the new map.

    If the toolbar is available in the new blank map document, the existing map document may be corrupt. To start working on a new mxd without missing toolbars:
    A. Open up the existing mxd (with the missing toolbar) side by side with a new blank mxd.
    B. Select all the layers in the corrupt mxd's table of contents.
    C. Drag them across to the blank mxd or copy/paste them into the new mxd.
    D. Save the new mxd.
  4. If the above steps do not show the toolbar, there may be an issue with the map template. Follow the steps below to refresh the map template:

    Windows XP

    A. Close ArcCatalog and ArcMap
    B. Navigate to root C:\Documents and Settings\CURRENT_USERNAME\Application Data\ESRI\Desktop10.0\ArcMap\Templates

    Note:
    The Application Data folder may be hidden. If so, select the Tools menu in Windows Explorer, and click Folder Options. Click the View tab and select 'Show hidden files and folders'.

    C. Open the Templates folder
    D. Right-click the file Normal.mxt and rename it. For example, Normalold.mxt. Re-start ArcMap.


    Windows 7

    A. Close ArcCatalog and ArcMap
    B. Navigate to root C:\Users\CURRENT_USERNAME\AppData\Roaming\ESRI\Desktop10.0\ArcMap\Templates

    Note:
    The Application Data folder may be hidden. If so, go to Start > Control Panel > Folder Options. Click the View tab and select 'Show hidden files, folders, and drives'.

    C. Open the Templates folder
    D. Right-click the file Normal.mxt file and rename it. For example, Normalold.mxt. Re-start ArcMap.


    Warning:
    If there are any custom toolbars or folder connections, they are removed because the procedure shown in Step 4 reverts the ArcMap normal template to the original installed template. If these changes are not desired, they can be reverted by deleting Normal.mxt and renaming Normalold.mxt to Normal.mxt in the directory above.

Related Information