问题

问题:将调查发布到 Portal for ArcGIS 时,未找到数据集

Last Published: April 27, 2022

描述

尝试将调查从 ArcGIS Survey123 Connect 或 ArcGIS Survey123 发布到 Portal for ArcGIS 将返回以下错误消息:

错误: 未找到数据集。 状态:错误。 详细信息:代码 500
错误: 获取结果参数时出错。 状态:错误。 详细信息:代码 500
错误: 无法创建新调查。 错误:未找到数据集。
ArcGIS Survey123 中的错误消息

原因

给定错误消息将指示一个更广泛的问题。 导致此错误的潜在原因包括但不限于:

  • Portal for ArcGIS 无法创建托管要素图层,这是发布过程的核心部分。
  • PublishingTools 或 PublishingToolsEx 地理处理服务未运行或需要重新启动。
  • ArcGIS Data Store 许可已过期。
  • 未在 ArcGIS Server 中验证 ArcGIS Data Store。
  • 未向用户分配将托管要素服务发布到 ArcGIS Server 的权限。
  • 发布到 Portal for ArcGIS 的 Survey123 表单仅包含一个地理点问题,其 bind::esri:fieldType 自定义列设置为 null。 有关详细信息,请参阅 BUG-000137465

解决方案或解决方法

  1. 查看 Portal for ArcGIS,以确保其能够发布托管要素图层。 通过使用 Portal for ArcGIS 创建图层(通过模板或直接上传 CSV 文件)对此进行测试。
: 如果未针对所有调查表单返回该错误,则可能存在配置问题或者调查 XLSForm 设计出现问题。 重新发布调查表单,或参阅 ArcGIS Survey123:XLSForm 基础知识以获取 XLSForm 设计最佳实践。
  1. 如果该错误仍然存在,请检查 PublishingTools 或 PublishingToolsEx 地理处理服务的状态。 有关详细信息,请参阅 ArcGIS Server:启动和停止服务
  2. 检查 ArcGIS Server Manager 日志以找出根本原因。 有关访问日志的步骤,请参阅 ArcGIS Server:服务器日志
    1. 运行 describedatastore.bat 实用程序。 有关 ArcGIS Data Store 命令实用程序参考的详细信息,请参阅 ArcGIS Enterprise:ArcGIS Data Store 命令实用程序参考
    2. 检查数据存储模式和可用磁盘空间。 如果数据存储模式设置为 READONLY,并且存在可用磁盘空间,请使用以下命令将关系数据存储设置为 READWRITE
changedatastoremode readonly|readwrite [--prompt <yes|no>]
: 当计算机上的磁盘空间不足时,数据存储模式将自动设置为 READONLY 以防止数据丢失。
  1. 在 Windows 中重新启动 ArcGIS Data Store 服务。
describedatastore.bat 的命令提示符

文章 ID:000022129

从 ArcGIS 专家处获得帮助

联系技术支持部门

下载 Esri 支持应用程序

转至下载选项

相关信息

发现关于本主题的更多内容