中文

问题:早期版本的 ArcGIS 无法读取在 Pro 2.3 中编辑或创建的镶嵌数据集

说明

在 Pro 2.3 中编辑或创建镶嵌数据集时,无法将其与早期版本的 ArcGIS 一起使用,例如 Pro 2.2、ArcMap 10.6.1 或 Server 10.6.1。

:
在 Pro 2.3 中创建的镶嵌数据集与 ArcGIS 10.7 兼容,其中包括 ArcGIS Enterprise、Server、ArcMap 和 REST API 10.7。

原因

通常,镶嵌数据集与并发版本及后续版本的 ArcGIS 兼容,但是无法使用较早版本 ArcGIS 读取和处理使用较新版本 ArcGIS 创建的镶嵌数据集。

table of version compatibility

由于在 Pro 2.3 中对镶嵌数据集的内部结构进行了重大更改,因此无法在较早版本中读取在 Pro 2.3 中创建或修改的镶嵌数据集。

解决方案或解决方法

无法使用早期版本读取使用 ArcGIS Pro 2.3 或 10.7 创建或修改的镶嵌数据集。 此问题已在 Pro 2.3.2 中修复。

  1. 请安装 ArcGIS Pro 2.3.2 修补程序。 登录到 My Esri 以下载修补程序
:
应用此修补程序之前,必须先安装 ArcGIS Pro 2.3
  1. 打开 Pro 2.3.2。
  2. 目录窗格中,导航至您的镶嵌数据集。 单击鼠标右键,然后从下拉菜单中选择属性
  3. 单击 Defaults 以显示 Image Properties。 向下滚动到 Maximum Number of Rasters Per Mosaic,然后将值更改为任何数值。 按 键以更新此字段。
  1. Maximum Number of Rasters Per Mosaic 属性更改回原始值,然后按 键以再次更新此字段。 单击确定

由此可将镶嵌数据集对象重置为新的 Pro 2.3.2 版本。 现在,即可使用 ArcGIS Pro 2.1 以及 10.5 或更高版本读取镶嵌数据集。

相关信息

下载:ArcGIS Pro 2.3.2 修补程序