中文

常见问题解答:如何在 ArcGIS Runtime SDK for Qt 上启用 TLS 1.2?

问题

常见问题解答:如何在 ArcGIS Runtime SDK for Qt 上启用 TLS 1.2?

答案

Esri 致力于为 ArcGIS 平台构建和提供强大的安全性,并通过使用最新的安全协议为我们的客户提供帮助。 我们不懈地努力实施最高行业标准,其中包括用于数据完整性和网络安全的 TLS。

为满足这些标准,Esri 正在 ArcGIS 平台上对软件进行更新,以支持 TLS 1.2。 作为改进 ArcGIS Online 安全性的一部分,Esri 正在要求 ArcGIS Online 服务使用 TLS 1.2 连接。 为确保对这些服务进行持续访问,需要采取一些措施。

注:
请参阅 Esri 支持中心网站上的产品生命周期页面,了解 ArcGIS Runtime SDK for Qt 每个版本的支持状态。

在 Windows、Linux 和 Android 平台上,使用 Qt Framework 的最低支持版(在系统要求上列出)或更高版本及 OpenSSL 1.0.1 的最低支持版或更高版本,可使 ArcGIS Runtime SDK for Qt versions 10.2.6 和 100.x 支持 TLS 1.2。 从 Qt 5.5 版本开始,iOS 和 macOS 的 Apple 安全传输框架开始默认支持 TLS 1.2。

推荐配置:

  • 最新版 Qt Framework(或至少为 ArcGIS Runtime SDK for Qt 支持的最低版本)
  • Windows、Android 和 Linux 的 OpenSSL 1.01 或更高版本
注:
有关如何在其他 Esri 产品中使用 TLS 1.2 的信息,请参阅 Esri 支持 TLS 页面

Related Information