中文

常见问题解答:如何在 ArcGIS Runtime SDK for Java 上启用 TLS 1.2?

问题

常见问题解答:如何在 ArcGIS Runtime SDK for Java 上启用 TLS 1.2?

答案

注:
请参阅 Esri 支持中心网站上的产品生命周期页面,了解 ArcGIS Runtime SDK for Java 每个版本的支持状态。

在所有受支持的平台上,若使用 Java 8 Update 181 或更高版本,则 ArcGIS Runtime SDK 100.4 和 10.2.x 版本都支持 TLS 1.2 而无需更改任何应用程序。
然而,在 Java 7 环境中使用 TLS 时,执行 ArcGIS 10.2.x 应用程序会返回 javax.net.ssl.SSLException 错误。
Esri 建议在 Java 8 Update 181 或更高版本上执行 ArcGIS 10.2.x 应用程序。

注:
有关如何在其他 Esri 产品中使用 TLS 1.2 的信息,请参阅 Esri 支持 TLS 页面

Related Information