中文

操作方法:配置 Windows 以为使用 .NET4 Framework 的应用程序使用 TLS 1.2

摘要

作为改进 ArcGIS Online 安全性的一部分,Esri 要求 ArcGIS Online 服务使用 TLS 1.2 连接。 为确保对这些服务进行持续访问,需要采取一些措施。

以下步骤描述了如何设置 Windows 操作系统以使用 TLS 1.2。 此操作将设置系统中所有依赖 Microsoft .NET4 Framework 的应用程序都使用 TLS 1.2。 此次更改为操作系统级操作,只可进行一次。 如果您在 Windows 上为其他 Esri 产品启用 TLS 1.2 时已经使用过这些说明并创建了 Windows 注册表项,则不必重复这些步骤。

当明确支持 TLS 1.2 的产品升级不可用或无法进行时,可以选择此方法配置 ArcGIS 应用程序使之可以使用 TLS 1.2。 建议的解决方法是升级到支持 TLS 1.2 的产品版本。

有关信息,请参阅 Esri 支持 TLS 页面。 请在决定要使用的方法时仔细考虑您的情况 - Esri 已证实设置 .NET 环境以启用 TLS 1.2 不会导致 ArcGIS 出现问题;但可能会通过更改默认 TLS 行为影响其他 .NET 应用程序。

如果系统使用 .NET 3.5.1 版本,且无法安装 .NET4,请参阅以下文章了解启用 TLS 1.2 的步骤:操作方法:配置 Windows 以为使用 .NET 3.5.1 Framework 的应用程序使用 TLS 1.2

过程

注意:
下面的说明涉及更改操作系统的重要组成部分。 建议在继续之前 
对操作系统和文件包括注册表进行备份。 必要时,请咨询有资历的计算机系统专业人士。
  1. 确保 Microsoft .NET4 已安装。
    请参阅操作方法:确定安装的 .NET Framework 版本
  2. 如有必要,可从 Microsoft 下载中心安装 .NET4:Microsoft .NET Framework 4.7(Web 安装程序)
  3. 下载并提取以下 .zip 文件:TLS_NET4.zip
  4. 提取文件 TLS_NET4.reg,打开文件以创建相应的 Windows 注册表项。
  5. 测试 TLS 1.2 与 ArcGIS Online 的连接

相关信息