中文

操作方法:在 ArcMap 中估算和构建大型栅格数据集的直方图

摘要

使用“分类”方法对单波段栅格进行符号化需要在栅格数据集上构建直方图。 但是,对于像元大小偏小的大型栅格(例如,30 x 30 个像元),为整个栅格数据集构建直方图可能非常耗时。

以下示例是归一化差值植被指数 (NDVI) 图层,像素大小约为 3.28 英尺。 要使用“分类”方法对 NDVI 图层进行符号化,必须构建直方图。 然而,考虑到精细的分辨率和较大的空间范围,扫描原始大型栅格数据集的所有像素值来计算直方图可能花费大量时间。 因此,更快速估算和构建直方图的方法是将栅格重采样为采样大小减小的栅格,在重采样栅格上构建直方图,再将直方图导入原始栅格。

:
使用重采样技术,重采样栅格并不完全代表原始数据分布。 
但是,此方法是一种以较小的样本大小逼近原始分布以更快地估算直方图的方法。

过程

此处提供的步骤介绍了如何通过重采样函数将大型栅格重采样为分辨率降低的栅格、如何使用统计数据和直方图函数将重采样栅格的直方图导入原始栅格数据集,以及使用分类符号系统对栅格图层进行符号化的方法。

  1. 在 ArcMap 主菜单中,单击窗口 > 影像分析
  2. 影像分析窗口中,启用并选择原始栅格。
  3. 单击添加函数按钮以打开函数模板编辑器
An image of enabling and selecting the raser layer in the Image Analysis window.
  1. 按以下步骤添加和应用重采样函数
    1. 函数模板编辑器中,右键单击标识函数 > 插入函数 > 重采样函数
An image of the Function Template Editor.
  1. 栅格函数属性对话框中,设置输入像元大小的原始像素大小,并将输出像元大小设置为较大像素大小,以降低输出栅格的分辨率。
An image of the Raster Function Properties dialog.
  1. 单击确定以应用函数。 此步骤将生成一个新图层,该图层是具有较粗空间分辨率的重采样栅格。
  1. 内容列表中右键单击新图层 > 属性,打开图层属性对话框。
  2. 单击符号系统选项卡 > 已分类 > 确定
  3. 计算直方图警告弹出窗口中单击
An image of the Compute Histogram dialog box.
  1. 右键单击图层 > 另存为图层文件,将具有已构建直方图的重采样栅格图层另存为图层文件。
An image of saving as layer file.
  1. 打开影像分析窗口,按以下步骤添加统计数据和直方图函数
    1. 影像分析窗口中,选择原始栅格数据集 > 添加函数
    2. 右键单击标识函数 > 插入函数 > 统计数据和直方图函数
An image of adding the Statistics and Histogram Function in ArcMap.
  1. 栅格函数属性对话框中,对于从文件中导入统计数据和直方图选项,浏览到步骤 8 中保存的图层文件,然后单击确定
  2. 函数模板编辑器中,单击确定以应用该函数。
:
要使用“分类”方法查看导入的直方图并对图层进行符号化,打开在步骤 9 中生成的新图层的“符号系统”窗口。
An image showing the histogram is added to the layer and can be symbolized using the Classified method.

相关信息