中文

漏洞:如果用于运行服务器的域帐户采用 UPN 格式,则 ArcGIS Enterprise 10.5 无法正确升级

说明

安装 ArcGIS Enterprise 产品时,会列出运行数据存储、服务器或门户服务的域用户。 如果指定此格式(使用下层域格式 - 域/用户),则安装和后续升级可按预期进行。

此外,可以指定 UPN (user@domain.com) 格式以通过“Microsoft 管理控制台”>“服务”来运行服务。 但是,如果使用 UPN 格式,则 Enterprise 产品的升级无法按预期进行。

原因

这是一个已知限制。 针对此行为,已记录以下漏洞:

  • BUG-000103854:如果用于运行 Server 的域帐户使用用户主体名称 (UPN) 格式,则 ArcGIS GIS Server 无法正确更新。
  • BUG-000103899:如果用于运行 Server 的域帐户使用用户主体名称 (UPN) 格式,则 Portal for ArcGIS 无法正确更新。
  • BUG-000103853:如果用于运行 ArcGIS Data Store 的域帐户使用用户主体名称 (UPN) 格式,则 ArcGIS Data Store 无法正确更新。
  • BUG-000103710:“配置 ArcGIS Server 帐户”实用程序无法将用户主体名称 (UPN) 格式识别为域用户。

解决办法

使用域帐户来运行 ArcGIS Enterprise 时,请使用下层域格式 - 域/用户。 以下屏幕截图显示了正确配置用户帐户的方法。

User-added image

以下屏幕截图显示了不推荐的配置。

User-added image

有关 UPN 和下层域格式的详细信息,请参阅“相关信息”部分中链接的以下 Microsoft 文档。

相关信息