中文

问题:使用 10.0.2 之前的 Safari 版本运行需要 WebGL 的 ArcGIS for JavaScript API 应用程序,可能会导致黑屏或绿屏

说明

运行任何使用 ArcGIS API for JavaScript 版本 4.x 构建的 Esri 或自定义应用程序,均可能导致 Apple Safari 浏览器上出现黑屏或绿屏。 其中包括场景查看器、Web AppBuilde、3D 模板、GeoPlanner 以及其他可能的程序。

原因

此问题是由于在 Apple Safari 浏览器中使用 WebGL(Web 图形库)出现问题所导致的。

解决方案或解决方法

如果出现此问题,请检查 Safari 的版本。 如果浏览器的版本不是 10.0.2 或更高版本,请升级浏览器。 如果没有升级选项,请使用其他浏览器作为解决方法。