中文

操作方法:在 ArcMap 中查找两个栅格之间的栅格值差异

摘要

“栅格计算器”和“减”工具等空间分析工具有助于深入了解地理上重叠的栅格图像之间的栅格值差异。 在 ArcGIS Desktop 中,这些工具位于 Spatial Analyst 工具箱中。 如果环境中没有 ArcGIS Spatial Analyst 扩展模块,则也可以使用“图像分析”窗口中的“差异”函数。

过程

:
“栅格计算器”和“减”工具需要 Spatial Analyst 许可。
 

下述说明介绍了用于查找两个栅格之间的栅格值差异的步骤。 方案 A 介绍了使用“地图代数”工具集中的“栅格计算器”工具时的工作流,而方案 B 则介绍了使用“数学”工具集中的“减”工具时的工作流。 方案 C 介绍了使用“图像分析”窗口中的“差异”工具查找栅格值差异的步骤,该工具不需要扩展模块。

  • 方案 A:使用“栅格计算器”
  1. 在 ArcMap 中,导航至 ArcToolbox > Spatial Analyst 工具 > 地图代数 > 栅格计算器
  2. 栅格计算器窗口中,双击其中一个待分析的栅格,单击减号 (-),然后再双击第二个栅格。
  3. 指定输出栅格的名称和位置。
  4. 单击确定
User-added image
 
  • 方案 B:使用“减”工具
  1. 在 ArcMap 中,导航至 ArcToolbox > Spatial Analyst 工具 > 数学 >
  2. 拖放要分析的栅格,或者通过单击文件夹图标指定栅格,以便为输入栅格或常量值 1输入栅格或常量值 2 字段选择栅格。
  3. 指定输出栅格的名称和位置。
  4. 单击确定
Image of the Math tool
 
  • 方案 C:使用“差异”函数
  1. 要在 ArcMap 中打开“影像分析”窗口,请在主菜单中单击窗口,然后单击影像分析
  2. 影像分析窗口中,单击所需的两个图层。
  3. 单击差异按钮 Difference。 随即将创建一个临时图层,用以显示栅格之间的差异。
Image Analysis Window
  1. 要保存步骤 3 中的图层,请右键单击该图层,然后导航至数据 > 导出数据。 为输出栅格数据集选择位置并指定名称,然后单击保存
Export raster
:
确保两个栅格的像素大小和投影相同。 如有必要,请使用“数据管理”工具箱中的重采样投影栅格工具分别更改栅格的像素大小和投影。 要确保输出栅格的精度,可以使用裁剪工具来对齐栅格的范围。  

相关信息