中文

操作方法:在 ArcMap 中显示 AutoCAD 工程图文件

摘要

本文说明了如何将 AutoCAD 工程图文件添加到 ArcMap 中,如何识别可能阻止数据绘制的问题,并提供了在 AutoCAD 中更正这些问题的提示。

过程

将文件添加到 ArcMap 之前,在应用于原生应用程序中的 AutoCAD 工程图文件时,以下步骤很有用。

:
ArcGIS Desktop 不支持使用对象数据在 AutoCAD Civil 3D 或 AutoCAD Land Desktop 中创建的要素。 如果打开这些文件并重新保存在 AutoCAD 中,则某些对象数据可能会转换为在 ArcMap 中绘制或转换为地理数据库的某些实体。 但如果可能,应避免在引入 ArcGIS Desktop 的 AutoDesk 文件中使用对象数据。
  1. 创建 AutoCAD 文件的副本。
    1. 在 AutoCAD 中以不包含空格或连字符的名称保存工程图文件的副本。 如果名称包含空格或连字符,则将两种字符替换为下划线。
    2. 导航至插入 > 外部引用,并分离附加到文件的任何外部引用。 再次保存 AutoCAD 工程图文件。
    3. 导航至格式 > 单位。 注意用于创建文件的单位。
    4. 导航至图层管理器,然后打开、解冻或解锁任何已关闭、冻结或锁定的图层。 由此,可以在 ArcMap 中绘制数据。
    5. 保存 AutoCAD 工程图文件。
  2. 将 AutoCAD 工程图文件添加至 ArcMap 以修改要素。
    1. 在 ArcMap 中打开一个空白地图。
[O-Image]
  1. 导航至工具工具栏,然后选择添加数据下拉菜单。
[O-Image]
  1. 浏览至保存 AutoCAD 工程图文件新副本的位置,然后双击 .dwg 文件。
[O-Image]
  1. 从文件中单独添加要素类型。 这有助于隔离导致问题的要素类型。
[O-Image]
:
 通过将要素类型单独添加至 ArcMap 可访问单独图层属性。 通过添加图层组可阻止访问此信息。
警告:
如果 ArcMap 会话中显示的数据出现任何问题,则必须修改 AutoCAD 工程图文件。 请参阅步骤 3-5。
  1. 在 ArcMap 中,从 .dwg 文件中移除有问题的图层。 右键单击特定图层,然后选择移除
[O-Image] [O]
 
  1. 在 AutoCAD 中,导航至编辑 > 全选,然后应用拆分命令来拆分该区块。
:
 “拆分”命令可能导致无法访问的要素可用。 建议至少应用一次“拆分”命令,但是该命令可能需要多次应用,因为区块最多可以嵌入九级深度。 
  1. 将工程图文件保存在 AutoCAD 中,然后重复步骤 2。

相关信息

上次修改时间: 11/21/2019

文章 ID: 000012483

软件: ArcMap 10.8, 10.7.1, 10.7, 10.6.1, 10.6, 10.5.1, 10.5, 10.4.1, 10.4, 10.3.1, 10.3, 10.2.2, 10.2.1, 10.2, 10.1, 10 ArcGIS for AutoCAD 350, 300