问题

问题:安装停止响应,未显示任何错误信息

Last Published: November 20, 2020

描述

在安装或卸载以下任何 9.2 产品或者其补丁包时,安装将停止响应:ArcGIS Server for the Microsoft .NET Framework、ArcIMS Web ADF for the Microsoft .NET Framework、Desktop SDK for the Microsoft .NET Framework、Engine SDK for the Microsoft .NET Framework 或 ArcGIS Explorer SDK。

注: 本文适用于 ArcGIS 9.2、9.3 和 9.3.1 版本。 更高版本的 ArcGIS 可能包含不同的功能,对于菜单、命令和地理处理工具,可能具有不同的名称和位置。

有时,当安装停止响应时,安装用户界面中将显示消息“正在注册 Visual Studio Express''。 否则,将不会提供任何信息。

原因

当 ArcGIS 安装停止响应时,计算机上存在以下三个 Microsoft Visual Studio Express Edition 产品中的一个或多个产品:Microsoft Visual Web Developer 2005 Express Edition、Microsoft Visual C# 2005 Express Edition 或 Microsoft Visual Basic 2005 Express Edition。
所有 Visual Studio 2005 Express Edition 都需要在安装后 30 天内进行注册。 30 天后,每次启动 Visual Studio Express Edition 时都会显示注册提示。 将某个产品安装到在 30 天窗口内未激活的 Visual Studio Express Edition 之上时,安装将停止响应,该产品可将模板集成到 Visual Studio Express 中。 同样,如果未在 30 天内注册 Visual Studio Express,则任何集成了 Visual Express 模板的产品都将在卸载期间停止响应。 Microsoft 已记录此问题。

解决方案或解决方法

  1. 当安装或卸载停止响应时,请按 CRTL+ALT+DEL 键。 单击任务管理器按钮,或者右键单击 Windows 开始栏并选择任务管理器
  2. 选择 Windows 任务管理器上的进程选项卡,然后定位以下进程:VWDExpress.exe、VCSExpress.exe、VBExpress.exe 以及具有格式 msi*.tmp 的任何进程。 根据所安装的 Visual Studio Express Edition,可能仅列出其中一个或多个。
  3. 右键单击此进程,然后选择结束进程树。 结束这些进程后,安装或卸载应成功完成。

文章 ID:000009443

从 ArcGIS 专家处获得帮助

联系技术支持部门

下载 Esri 支持应用程序

转至下载选项

相关信息

发现关于本主题的更多内容