问题

问题:无法在 ArcGIS Survey123 Connect 中更新并发布调查

Last Published: April 27, 2022

描述

当使用 ArcGIS Survey123 Connect 发布调查时,将在 ArcGIS Online 中创建调查的文件夹,其中包含要素图层、表单项目和 web 地图。 由此即可灵活地迁移 ArcGIS Online 内容。 在某些情况下,当使用 Survey123 Connect 更新并重新发布调查时,发布过程将加载但未完成,如下图所示:

加载且未完成的 ArcGIS Survey123 Connect 中的调查发布页面。

原因

在 ArcGIS Online 中将调查的表单项目移至另一个文件夹后,会出现此问题。 由此导致表单项目所在的 ArcGIS Online 文件夹的项目 ID 与调查的本地 ITEMINFO 文件中的 ID 不匹配。

最初发布调查后,可将存储表单项目的 ArcGIS Online 文件夹的 ID 本地保存在 ITEMINFO 文件中。 随后每次发布调查时,ITEMINFO 文件中的 ID 必须与存储表单项目的 ArcGIS Online 文件夹的 ID 相匹配。

ArcGIS Online 文件夹中的表单项目包含的 ID 必须与本地保存的 ITEMINFO 文件中的 ID 相匹配

解决方案或解决方法

要解决此问题,请按照以下步骤编辑调查的 ITEMINFO 文件,以确保项目 ID 与存储表单项目的 ArcGIS Online 文件夹 ID 相匹配。

  1. 在 ArcGIS Online 中,导航至内容 > 我的内容
  2. 导航至存储表单项目的文件夹,然后从 web 浏览器的地址栏中复制该文件夹的项目 ID,如下图所示。
调查文件夹的页面在地址栏中显示了该文件夹的项目 ID。
  1. 在本地计算机上,导航至调查文件夹,然后使用文本编辑器打开调查的 ITEMINFO 文件。
通过在本地计算机的“文件资源管理器”目录中进行导航以打开调查的 ITEMINFO 文件。
  1. 搜索 "ownerFolder" 参数,并确保该值与步骤 2 中的项目 ID 相匹配。 如果项目 ID 不同,请将参数值更新为在步骤 2 中复制的项目 ID,然后单击保存
在 ArcGIS Online 中修改 ownerFolder 参数,以确保其与调查文件夹的项目 ID 具有相同的项目 ID。
  1. 从 Survey123 Connect 中重新发布该调查。

文章 ID: 000025001

接收通知并查找新问题或常见问题的解决方案

从我们全新的 AI 聊天机器人中获得简明答案和视频解决方案。

下载 Esri 支持应用程序

相关信息

发现关于本主题的更多内容

获取来自 ArcGIS 专家的帮助

联系技术支持部门

下载 Esri 支持应用程序

转至下载选项