问题

问题:无法在 Portal for ArcGIS 中登录和创建新帐户

Last Published: October 14, 2021

描述

在某些情况下,首次尝试登录到 Portal for ArcGIS 将失败,并且无法创建新用户帐户。 如果在登录时未自动创建帐户,则特定于组织的用户可以访问门户,但仅具有没有 ArcGIS 组织帐户的用户的权限。

原因

  • “enableAutomaticAccountCreation”设置设置为“false”。
  • ArcGIS Web Adaptor 配置错误。 例如,“Windows 身份验证”选项在 Internet Information Server (IIS) 管理器中禁用。

解决方案或解决方法

根据具体原因,请选择以下选项之一来解决这一问题。

将 enableAutomaticAccountCreation 设置设置为“true”

  1. 使用管理员帐户登录到 Portaladmin API。 例如:
https://portal.domain.com:7443/<Web Adaptor 名称>/portaladmin
  1. 选择安全 > 配置 > 更新安全配置
  2. enableAutomaticAccountCreation 配置编辑为 true
  3. 单击更新配置
在“更新安全配置”页面中,将 enableAutomaticAccountCreation 配置设置为“true”。

正确配置 ArcGIS Web Adaptor

在 Internet Information Server (IIS) 管理器中正确配置 ArcGIS Web Adaptor。 有关步骤,请参阅 Portal for ArcGIS:配置 ArcGIS Web Adaptor 以使用 IWA

文章 ID:000026600

从 ArcGIS 专家处获得帮助

联系技术支持部门

下载 Esri 支持应用程序

转至下载选项

相关信息

发现关于本主题的更多内容