问题

问题:ArcGIS Server Manager 日志中的查询结果不一致

Last Published: June 26, 2024

描述

在某些情况下,当在 ArcGIS Server Manager 中访问服务器日志时,日志会显示不一致的结果。 例如,对于某些过滤器,首次查询会显示正确的结果,而后续查询会显示错误或奇怪的结果。

原因

ArcGIS Server Manager 中的日志文件已损坏,但在 ArcGIS Server Administrator Directory 中查看日志时,却无任何不一致之处。

解决方案或解决方法

执行清理操作。 清理操作将强制服务器清理日志,由此释放磁盘空间。

Warning:   
This operation is irreversible. Once invoked, this operation deletes all logs on every server machine on the site.
Note:
It is recommended to create a backup of the ArcGIS Server site configuration before proceeding with the following steps. Refer to ArcGIS Server: Making a backup of your site for instructions.
  1. 以管理员身份登录到 ArcGIS Server Administrator Directory。 默认 URL 为:
https://<gisserver>.<domain.com>:6443/arcgis/admin
  1. 对于资源,单击日志
  2. 对于受支持的操作,单击清除
  3. 清除理日志页面上,从格式下拉菜单中选择相应格式,然后单击清除
  4. 重新启动 ArcGIS Server 服务。 有关说明,请参阅 ArcGIS Server:启动和停止服务
Note:
Do not copy the old logs from the backup folder to the newly cleaned directory. If required, explore the old logs from the backup folder.

文章 ID: 000032770

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