问题

问题:ArcGIS Enterprise 的 Portal for ArcGIS 组件修补程序在 Windows 上冻结

Last Published: August 4, 2021

描述

在某些 Windows 系统上,为 ArcGIS Enterprise 的 Portal for ArcGIS 组件安装修补程序可能会导致显示消息“安装程序已不再响应”。

安装程序消息

原因

Portal for ArcGIS 组件包含大量文件,安装技术将维护所有已安装文件的完整列表。 在修补程序运行期间维护列表会占用大量系统资源,这可能导致计算机运行较慢或 VM 花费的时间比 Windows Installer 技术的预期时间更长。  

解决方案或解决方法

有多种机制可以避免此问题或最大限度地避免其发生。

  1. 在可能的情况下使用 /qn 静默安装选项。 这完全避免了问题。  
     
    通过高级命令提示符运行以下命令:

    <patchname.msp> /qn

    例如:

    ArcGIS-109-S-ALPI-Patch.msp /qn
  1. 如果您在交互式修补程序安装过程中收到“安装程序已不再响应”警告,仅需单击“重试”。 在某些系统上,您可能会多次收到警告,并且每次都可以继续。 安装程序最终将完成。

考虑暂时禁用任何会降低文件操作速度的进程,例如防病毒软件和其他安全软件。 这将减少遇到此问题的可能性。  

为安装目录使用尽可能快的存储,例如 SSD 支持的存储。 SSD 支持的存储上更短的寻道时间显著减少了安装时间并减少了遇到此问题的可能性。

文章 ID: 000026175

接收通知并查找新问题或常见问题的解决方案

从我们全新的 AI 聊天机器人中获得简明答案和视频解决方案。

下载 Esri 支持应用程序

发现关于本主题的更多内容

获取来自 ArcGIS 专家的帮助

联系技术支持部门

下载 Esri 支持应用程序

转至下载选项