问题

问题:ArcGIS Desktop 安装冻结,并且不显示任何错误消息

Last Published: January 6, 2021

描述

在 ArcGIS Desktop 安装过程结束或接近结束时,安装冻结;未显示任何错误。

注: 本文适用于 ArcGIS 9.x 版本。 更高版本的 ArcGIS 可能包含不同的功能,对于菜单、命令和地理处理工具,可能具有不同的名称和位置。

原因

存在无效或损坏的文件,或者安装程序正在将文件复制到安装程序无权写入或覆盖文件的目录。

解决方案或解决方法

要解决此问题,请创建安装日志文件以定位问题文件。

  1. 导航至开始 > 运行,然后输入以下内容:
代码: msiexec /i D:\setup.msi /L*v C:\logme.log

使用计算机 CD-ROM 驱动器的正确字母替换以上 D:。

  1. 运行安装,直至其冻结为止。
  2. 查看文件 logme.log。 最后一个条目应指示导致冻结的文件。
  3. 验证所有用户是否对目录结构或者安装程序尝试覆盖的文件具有完全读/写访问权限。

文章 ID:000009055

从 ArcGIS 专家处获得帮助

联系技术支持部门

下载 Esri 支持应用程序

转至下载选项

发现关于本主题的更多内容