操作方法

错误:无法在 ArcGIS Enterprise 中使用 IDP 进行登录。 IDP 支持加密 SAML 声明,但发送了未加密断言

Last Published: August 24, 2024

描述

尝试使用安全声明标记语言 (SAML) 登录到 ArcGIS Enterprise 时,将返回以下错误:

Error:   
Unable to login using Idp. IDP supports Encrypted SAML Assertion, but sends unencrypted Assertion
将返回错误消息:“无法使用 IDP 进行登录。 IDP 支持加密 SAML 声明,但发送了未加密声明。”

原因

  • 已在 Portal for ArcGIS 中启用“加密声明”选项。
  • 未将 samlcert 证书导入身份提供者 (IDP) 门户。

解决方案或解决方法

禁用“加密声明”选项

  1. 登录到 Portal for ArcGIS,然后单击组织 > 设置 > 安全性
  2. 登录部分中,选择 IDP。
  3. 指定属性页面上,展开显示高级设置
  4. 禁用加密声明选项。
  5. 单击保存

将 samlcert 证书导入 IDP 门户

Note: 
The following workaround may require the assistance of the organization's IT team.
  1. 禁用“加密声明”选项。
    1. 登录到 Portal for ArcGIS,然后单击组织 > 设置 > 安全性
    2. 登录账户部分中,选择身份提供者。
    3. 指定属性页面上,展开显示高级设置
    4. 禁用加密声明选项。
    5. 单击保存
  2. 导出 samlcert 证书。
    1. 登录到 ArcGIS Portal Administrator Directory
    2. 单击安全性 > SSLCertificates
    3. 单击现有 samlcert 证书。
    4. 单击导出
  3. 将 samlcert 证书导入 IDP 门户,然后找到令牌加密设置。
  4. 导入 samlcert 证书后将其激活。
  5. 启用“加密声明”选项。
    1. 登录到 Portal for ArcGIS,然后单击组织 > 设置 > 安全性
    2. 登录部分中,选择 IDP。
    3. 指定属性页面上,展开显示高级设置
    4. 启用加密声明选项。
    5. 单击保存
  6. 清除浏览器缓存并使用 SAML 登录账户重新登录。

文章 ID: 000031784

获得人工智能支持

使用 Esri Support AI Chatbot 快速解决您的问题。

立即开始聊天

相关信息

发现关于本主题的更多内容

获取来自 ArcGIS 专家的帮助

联系技术支持部门

立即开始聊天

转至下载选项