错误

错误:Portal for ArcGIS:抱歉,您没有访问此应用程序的权限

Last Published: October 14, 2024

错误消息

尝试从 Portal for ArcGIS“内容”页面访问 ArcGIS Experience Builder 应用程序时,将返回以下错误消息:

Error: 
Sorry, you do not have permissions to access this application.

此外,尝试在 Portal for ArcGIS 中编辑或删除该应用程序将失败。

原因

该应用程序已损坏。 由此 Portal for ArcGIS 无法标识该应用程序。

解决方案或解决方法

以下两个工作流可用于标识损坏的内容并解决该问题。

Note:
The workflows require administrative privileges to modify the files stored in the Portal install directories for the application.

查看 iteminfo.xml 文件

当 Experience 损坏时,通常是因为向 iteminfo.xml 文件内容添加了附加字符。

Note:
It is recommended to back up the XML file and validate it using an XML validation tool.
  1. 打开 XML 文件并使用文本编辑器对其进行编辑。 iteminfo.xml 文件的默认文件路径目录为:
C:\arcgisportal\content\items\<GUID of experience Builder application>\esriinfo\
  1. 搜索并移除以下加粗文本的示例:
    • 结束标签中包含附加 n> 标签,例如:</ESRI_ItemInformation>n>,而非 </ESRI_ItemInformation>
    • 结束标签中的随机字符,例如:adbasdhjasdhjh</url></ESRI_ItemInformation>

重新创建 PBF 文件

如果上一个工作流无法解决该问题,建议重新创建 PBF 文件。

  1. 导航至 Portal 目录,然后将 PBF 文件重命名为 iteminfo_old.pbf
  2. 启动 Experience。
Note:
If the PBF file is not available in the Portal directory, launch the Experience. Launching the Experience recreates the file.
PBF 文件

文章 ID: 000032602

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