中文
Continue in the app

ArcGIS for Server Security (January 2015) Patch

摘要

此安全修补程序可解决 ArcGIS for Server 中发现的漏洞。 Esri 建议所有使用 ArcGIS Server 10.1 SP1 QIP 和 10.2 的客户都应用此修补程序。 使用 10.2 的客户应首先应用 10.2.1 或 10.2.2。

说明

简介


Esri® 宣布推出 ArcGIS for Server Security (January 2015) Patch。 Esri 建议所有使用 ArcGIS for Server 10.1 SP1 QIP、10.2.1 和 10.2.2 的客户都应用此修补程序。 此修补程序专门处理此修补程序解决的问题下方列出的问题。


Esri 强烈建议在所有产品上安装最新的安全修补程序。 如果您使用 ArcGIS Web Adaptor for Java,则必须安装 ArcGIS Web Adaptor for Java (January 2015) Security Patch


此安全修补程序为累积修补程序,其中包括来自早期修补程序、ArcGIS 10.2.2 for (Desktop, Engine, Server) Geodatabase and Feature Service Sync Optimization Patch 的一些非安全相关修复程序。 来自早期修补程序(NIM08625、NIM099098、NIM100503、NIM091900、NIM094929、NIM088921、NIM098196、NIM100823、NIM101030和NIM101204)的一些地理数据库修复程序需要升级地理数据库才能生效。 安全修复程序无需升级地理数据库即可生效,并且如果不升级地理数据库,也不会出现新问题。


在 Windows 上安装此修补程序


安装步骤:


在安装此修补程序之前,必须先安装 ArcGIS 10.1 SP1 QIP、10.2.1 或 10.2.2 for Server。

  1. 将相应的文件下载到 ArcGIS 安装位置以外的其他位置。

  2.     校验和 (Md5)
    ArcGIS 10.1 SP1 QIP for Server ArcGIS-101SP1QIP-S-SEC-JAN2015-Patch.msp 110DE2A0F44A93036F224F5DFFE640D4
         
    ArcGIS 10.2.1 for Server ArcGIS-1021-S-SEC-JAN2015-Patch.msp

    07BADADBBCD98D13916F81E035E94D6B

         
    ArcGIS 10.2.2 for Server ArcGIS-1022-S-SEC-JAN2015-Patch.msp 4E1D47EA5A9E6B9F27DC1374588FB91F

  3. 请确保具有对 ArcGIS 安装位置的写入权限。

  4. 双击 ArcGIS-<版本>-S-SEC-JAN2015-Patch.msp 以启动安装过程。

    注:如果双击 MSP 文件后未启动安装程序安装进程,可使用下列命令手动启动安装程序安装进程:

    msiexec.exe /p [修补程序位置]\ArcGIS-<版本>-S-SEC-JAN2015-Patch.msp

在 Linux 上安装此修补程序


安装步骤:


以 ArcGIS 安装所有者身份完成以下安装步骤。 安装所有者为 arcgis 文件夹的所有者。

在安装此修补程序之前,必须先安装 ArcGIS 10.1 SP1 QIP、10.2.1 或 10.2.2 for Server。

  1. 将相应的文件下载到 ArcGIS 安装位置以外的其他位置。


        校验和 (Md5)
    ArcGIS 10.1 SP1 QIP for Server ArcGIS-101SP1QIP-S-SEC-JAN2015-Patch-lx.tar 5CF0C911B724D2C0C26A8E2F24F756FD
         
    ArcGIS 10.2.1 for Server ArcGIS-1021-S-SEC-JAN2015-Patch-lx.tar 99C583EFEAB77235B5EE4AB03DD9D591
         
    ArcGIS 10.2.2 for Server ArcGIS-1022-S-SEC-JAN2015-Patch-lx.tar 88E41239EEE837216C8B9F4A6BCD939A

  2. 请确保具有对 ArcGIS 安装位置的写入权限,并且当前没有用户正在使用 ArcGIS。

  3. 输入下列命令提取指定的 tar 文件:

    % tar -xvf ArcGIS-<版本>-S-SEC-JAN2015-Patch-lx.tar

  4. 输入下列命令启动安装过程:

    % ./applypatch

    这将启动菜单驱动安装步骤的对话框。 默认选择在括号 ( ) 中注明。 您可随时输入“q”退出安装流程。

卸载此修补程序

要在 Windows 上卸载此修补程序,请打开 Windows 控制面板,然后导航至已安装的程序。 确保“查看已安装的更新”(位于“程序和功能”对话框的左上角)处于活动状态。 从程序列表中选择 ArcGIS for Server Security (January 2015) Patch,然后单击“卸载”以移除该修补程序。

要在 Linux 上卸载此修补程序,您需要完全卸载 ArcGIS for Server 产品。 有关卸载 ArcGIS for Server 的详细信息,请参阅在 Linux 上卸载 ArcGIS for Server 页面。

修补程序更新

请定期访问修补程序和补丁包页面,以检查是否存在其他可用的修补程序。 将在此处发布有关此修补程序的最新信息。

2015 年 2 月 9 日:ArcGIS 10.1 SP1 QIP 版本现已发布。

2015 年 2 月 18 日:ArcGIS 10.2.2 版本现已发布。

如何确定已安装的 ArcGIS 产品

要确定已安装的 ArcGIS 产品,请选择适用于您的环境的适当 PatchFinder 实用程序版本,然后在本地计算机上运行它。 PatchFinder 将列出已在本地计算机上安装的所有产品、热修复程序和修补程序。

获取帮助

如果在安装此修补程序时遇到任何问题,美国用户请拨打 Esri 技术支持热线 1-888-377-4575。 国际用户请联系您当地的 Esri 软件分销商