中文
Continue in the app
漏洞编号 BUG-000134077
已提交 Sep 23, 2020
Modified Jun 01, 2022
严重性 Medium
应用于 ArcGIS Enterprise
找到的版本 No Version Found
程序语言 N/A
服务器平台 N/A N/A
客户端平台 N/A N/A
数据库 N/A
区域设置 N/A
状态 Unknown Text - Bugs/Fixed
Learn more
修正版本 10.9
SP 修复 N/A

漏洞 BUG-000134077

摘要

The OAuth Authorization code granted with Proof Key for Code Exchange (PKCE) fails in ArcGIS Enterprise 10.8.1.


附加信息

Support for the OAuth Authorization code granted with PKCE is added in ArcGIS Enterprise 10.8.1, but the workflow to use it differs from how it is used in ArcGIS Online. Changes are needed so they match.


备用解决方案

The Portal for ArcGIS Security 2021 Update 1 Patch includes a resolution for this bug. Refer to the following URL, https://support.esri.com/en/download/7899.