русский

FAQ: Как мне активировать TLS 1.2 для ArcGIS Runtime SDK for Qt?

Question

Как мне активировать TLS 1.2 для ArcGIS Runtime SDK for Qt?

Answer

Esri стремится создавать и обеспечивать надежную безопасность для платформы ArcGIS и помогает своим пользователям, используя новейшие безопасные протоколы. Мы стремимся внедрять самые высокие отраслевые стандарты, в том числе TLS для обеспечения целостности данных и сетевой безопасности.

Чтобы соответствовать этим стандартам, Esri вносит обновления программного обеспечения на платформе ArcGIS для поддержки TLS 1.2. В рамках улучшения безопасности ArcGIS Online, Esri требует использовать TLS 1.2 для сервисов ArcGIS Online. Необходимо принять меры для обеспечения постоянного доступа к этим сервисам.

Примечание:
См. страницы жизненного цикла продуктов на сайте Esri Support, где указан статус поддержки для каждой версии ArcGIS Runtime SDK for Qt

ArcGIS Runtime SDK for Qt версии 10.2.6 и 100.x может поддерживать TLS 1.2, путём использования минимальных поддерживаемых версий Qt Framework (перечислены в Системных требованиях) или выше и как минимум OpenSSL 1.0.1 или выше на платформах Windows, Linux и Android. Начиная с Qt 5.5, iOS и macOS поддерживают TLS 1.2 по умолчанию в среде Apple's SecureTransport.

Рекомендуемые требования:

  • Самая новая версия Qt Framework (или как минимум версия, поддерживаемая ArcGIS Runtime SDK for Qt)
  • OpenSSL 1.01 или выше для Windows, Android и Linux
Примечание:
См. Страницу поддержки TLS на Esri для получения более подробной информации о том, как использовать TLS 1.2 с прочими продуктами Esri .

Related Information