ERRO

O portal foi inicializado e configurado, mas não está acessível. O banco de dados interno do portal não parece estar em execução ou aceitando conexões

Last Published: October 1, 2021

Mensagem de Erro

Não foi possível acessar a página inicial do portal com a seguinte mensagem de erro grave retornada nos logs do portal:

Erro: O portal foi inicializado e configurado, mas não está acessível. O banco de dados interno do portal não parece estar em execução ou aceitando conexões.

Essa mensagem de erro é retornada nas seguintes situações:

  • Atualizando para uma versão mais recente do Portal for ArcGIS.
  • Reiniciando o serviço do portal.
  • O servidor foi desligado incorretamente. Por exemplo, durante uma interrupção.
  • Após não conseguir publicar conteúdo no Portal for ArcGIS.

Causa

  • O Portal for ArcGIS não pode acessar o armazenamento de dados pois o armazenamento de dados está no modo de somente leitura devido ao espaço em disco insuficiente.
  • RAM insuficiente na máquina do portal. Consulte Portal for ArcGIS: Requisitos de hardware para obter mais informações.
  • A conta de serviço especificada ao configurar o Portal for ArcGIS é diferente da conta de serviço especificada ao configurar ArcGIS Server e ArcGIS Data Store. Todos os componentes no ArcGIS Enterprise devem usar as mesmas contas de serviço.
  • O Portal for ArcGIS está configurado incorretamente ou federado.

Solução ou Solução Provisória

Dependendo da causa, use uma das seguintes soluções para resolver o problema.

Certifique-se que haja espaço em disco e RAM suficientes na máquina do portal

  1. Aumente o espaço em disco da máquina do ArcGIS Data Store. Para mais informações, consulte ArcGIS Enterprise: Requisitos de espaço em disco.
  2. Altere a configuração do armazenamento de dados relacionais do modo de somente leitura para leitura/gravação. Consulte a seção de solução deste artigo, Erro: Falha ao criar novas feições. Falha de Função Geral [ocorreu um erro do banco de dados.] para mais informações.

Configurar o Portal for ArcGIS para usar a mesma conta de serviço do ArcGIS Server e ArcGIS Data Store

Portal for ArcGIS, ArcGIS Server e ArcGIS Data Store podem ser configurados para usar uma conta de domínio, uma conta local ou uma conta de serviço gerenciado do grupo (gMSA). O mesmo tipo de conta de serviço deve ser usado para todos os componentes no ArcGIS Enterprise.

Para alterar a conta de serviço usada no Portal for ArcGIS, consulte ArcGIS Enterprise: Alterar a conta do Portal for ArcGIS.

Para alterar a conta de serviço usada no ArcGIS Server, consulte ArcGIS Enterprise: Alterando a conta do ArcGIS Server.

Para alterar a conta de serviço usada no ArcGIS Data Store, consulte Portal for ArcGIS: conta do ArcGIS Data Store.

Restaure o portal para uma instância de trabalho anterior usando a ferramenta da cópia de segurança webgisdr

Uma instância de trabalho anterior do portal pode ser restaurada usando a ferramenta webgisdr. Consulte Portal for ArcGIS: Restaurar o ArcGIS Enterprise.

Desinstalar e instalar o Portal for ArcGIS.

Aviso: As instruções abaixo incluem fazer alterações em partes fundamentais da implantação do ArcGIS Enterprise. A Esri recomenda fazer uma cópia de segurança da máquina do ArcGIS Enterprise, incluindo o registro, antes de continuar. A Esri não pode garantir resultados de modificações incorretas ao seguir estas instruções. Precaução no exercício. Consulte um profissional de sistemas de computador qualificado, se necessário.
  1. Faça uma cópia de segurança do diretório de conteúdo do portal e salve a cópia de segurança em um local temporário.
  2. Desinstale o Portal for ArcGIS. Para obter as etapas, consulte Microsoft: Desinstalar ou remover aplicativos e programas no Windows 10.
  3. Reinstale a versão anterior do Portal for ArcGIS. Para obter as etapas, consulte ArcGIS Enterprise: Instalando o Portal for ArcGIS.
  4. Assim que a instalação for concluída, crie o site Portal for ArcGIS apontando-o para o local do diretório de conteúdo original.

ID do Artigo:000026498

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download

Informações Relacionadas

Descubra mais sobre este tema