ERRO

Não foi possível registrar usando IDP. 'NAME_ID' não encontrado na resposta de SAML para AD FS

Last Published: July 22, 2021

Mensagem de Erro

Ao usar o IDP de SAML dos Serviços de Federação do Active Directory (AD FS), o seguinte erro é retornado ao tentar o registro no portal ArcGIS Enterprise via logins de SAML:

Não foi possível registrar usando Idp. 'NAME_ID' não encontrado na resposta de SAML

Causa

O atributo NameID de SAML está faltando no elemento <Assunto> da resposta de asserção SAML.

Solução ou Solução Provisória

  1. Abra o console de gerenciamento do AD FS.
  2. Selecione Contar com Terceiros de Confiança. Na janela Contar com Parte Confiável, selecione o SP correspondente ao seu portal enterprise.
  3. Na guia Ações, clique em Editar Política de Emissão de Solicitação (ADFS 4) ou Editar Regras de Solicitação (ADFS 3) e selecione a Regra de Transformação de Emissão e clique em Editar Regra.
  4. Na janela Editar Regra, clique em Visualizar Idioma da Regra.
  5. Verifique se o atributo Name ID é enviado usando o tipo: http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier
  6. Se este atributo estiver ausente, adicione uma nova declaração para o atributo Name ID. Para o tipo de declaração de Saída, escolha o valor Name ID na lista suspensa de opções.

ID do Artigo:000026098

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download

Informações Relacionadas

Descubra mais sobre este tema