PROBLEMA

Serviços de Armazenamento na Nuvem e ArcGIS Pro

Last Published: May 24, 2022

Descrição

O ArcGIS Pro atualmente não oferece suporte ao uso de serviços de armazenamento na nuvem, como OneDrive e Google Drive, a menos que seja declarado de outra forma na interface de usuário do ArcGIS Pro ou na documentação sobre ferramentas e funcionalidades específicas.

A equipe de Desenvolvimento do Software ArcGIS Pro está trabalhando para fornecer mais suporte para armazenamento na nuvem em versões futuras. Este artigo será atualizado para refletir o status de suporte mais recente.

Dois outros objetivos deste artigo são descrever problemas comuns encontrados ao trabalhar com ArcGIS Pro e serviços de armazenamento na nuvem e fornecer orientação, quando possível, para evitar problemas para aqueles que não podem evitar o uso de armazenamento na nuvem.

Embora existam muitos serviços de armazenamento na nuvem diferentes disponíveis, este artigo se concentra no OneDrive, pois é o serviço mais comumente usado pelos usuários do ArcGIS Pro. Se você usar outro serviço, poderá enfrentar os mesmos problemas e tomar medidas semelhantes para evitá-los. Observe que os arquivos armazenados no SharePoint apresentam muitas das mesmas características e comportamentos daqueles armazenados no OneDrive.

Causa

A maioria dos problemas relacionados ao armazenamento na nuvem acontecem devido ao seguinte:

  • Os arquivos que normalmente são editados ou acessados um de cada vez podem ser editados ou modificados simultaneamente por vários usuários. Isso faz com que os nomes dos arquivos mudem para uma máquina ou usuário e sejam compartilhados com outro. Além disso, as edições de várias pessoas podem ser sincronizadas com arquivos relacionados ao mesmo tempo, resultando em perda de dados ou inconsistência.
  • Os arquivos que devem ser bloqueados ou temporariamente imutáveis podem ser alterados.
  • Arquivos que são sempre armazenados com outros arquivos (por exemplo, arquivos em um geodatabase) podem não estar todos disponíveis localmente—eles podem ser divididos entre o armazenamento local e na nuvem e desempenho lento ou fazer com que os procedimentos falhem enquanto o conjunto completo de arquivos estiver sendo montado localmente.
  • O serviço de armazenamento na nuvem pode começar a sincronizar cópias de arquivos locais modificados para a nuvem em sua própria linha de tempo, evitando que o ArcGIS Pro grave no arquivo quando ele espera.

Solução ou Solução Provisória

Embora não sejam soluções completas, muitos problemas podem ser evitados tomando estas medidas:

  • Use o OneDrive para compartilhar arquivos com colegas e outros computadores fora de uma sessão do ArcGIS Pro. Ou seja, use seu sistema operacional ou navegador para copiar arquivos e copie-os para uma pasta fora do OneDrive para que possam ser acessados através do ArcGIS Pro.
  • Se combinar ArcGIS Pro e OneDrive for inevitável:
    • Não permita o acesso de vários usuários aos arquivos ou a edição simultânea de arquivos. Isso evita que várias cópias do mesmo arquivo sejam criadas e evita confusão sobre quais edições são aplicadas.
    • Desative a sincronização do OneDrive enquanto trabalhar no ArcGIS Pro. Por exemplo, desative a sincronização durante o dia e use o ArcGIS Pro apenas durante o dia. Qualquer confusão sobre qual arquivo foi atualizado por último é evitada.
    • Ao acessar com frequência uma pasta, faça com que o OneDrive sempre torne a pasta disponível localmente em seu computador. Isso evita atrasos e erros ao acessar arquivos que estão disponíveis somente online no momento que são acessados.
    • Não acesse arquivos ou execute ações que gerem tipos de arquivos .lock relacionados através do ArcGIS Pro (por exemplo, editar uma classe de feição). Isso pode criar erros de sincronização e, se várias máquinas forem sincronizadas, os arquivos de bloqueio serão baixados para cada uma delas.
    • Acesse arquivos no OneDrive diretamente do local onde eles estão sincronizados com o computador local. Por exemplo, arraste e solte os arquivos no ArcGIS Pro a partir do File Explorer. Não acesse e abra os arquivos de um navegador da web.

As seções subsequentes descrevem alguns problemas específicos que foram identificados.

Sincronização automática da pasta Documentos
Algumas organizações—principalmente as maiores—configuram as pastas de documentos de todos os seus membros para serem sincronizadas com o OneDrive para se beneficiar da cópia de segurança e de outros recursos do OneDrive. O ArcGIS Pro armazena arquivos, como arquivos de projeto e seus geodataases e caixas de ferramentas padrão, na pasta Documentos do usuário por padrão, por exemplo:  C:\Users\<nome do usuário>\Documents. Nesses ambientes, você pode ter problemas. A causa pode ser difícil de detectar, pois a sincronização do OneDrive pode ser tão perfeita que passa despercebida por muitos membros da organização. Verifique com seu departamento de TI se você não tiver certeza se a pasta Documentos é sincronizada automaticamente com o OneDrive.

Sugestão: Configure o ArcGIS Pro para criar projetos, geodatabases e caixas de ferramentas em outra pasta que não esteja sincronizada com o OneDrive.

Dados do caminho usando URLs do SharePoint ou OneDrive
Arquivos e pastas armazenadas no OneDrive são URLs atribuídas que podem ser compartilhadas e usadas por outras pessoas para acessar os dados através de HTTP. O ArcGIS Pro tem a opção de Adicionar dados de um caminho, que é usado para adicionar dados de caminhos ou URLs locais. No entanto, a tentativa de adicionar uma URL do OneDrive ou do SharePoint causa erros.

Sugestão: Copie os dados para uma pasta fora do SharePoint ou OneDrive e conecte-se a ela de lá. Por exemplo, copie-o para uma unidade de rede que não esteja sincronizada com o OneDrive e use o caminho da pasta para se conectar ao ArcGIS Pro.

ID do Artigo:000025605

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