Português

FAQ: Como habilito o TLS 1.2 para o ArcGIS Runtime SDK for Qt?

Question

Como habilito o TLS 1.2 para o ArcGIS Runtime SDK for Qt?

Answer

A Esri está comprometida em construir e fornecer forte segurança para a plataforma ArcGIS e ajudar nossos clientes usando os protocolos de segurança mais recentes. Nós nos esforçamos para implementar os mais altos padrões do setor, incluindo TLS para integridade de dados e segurança de rede.

Para atender a esses padrões, a Esri está fazendo atualizações de software na Plataforma ArcGIS para suportar o TLS 1.2. Como parte da melhoria da segurança do ArcGIS Online, a Esri está exigindo conexões TLS 1.2 para os serviços do ArcGIS Online. É necessária uma ação para garantir o acesso contínuo a eles.

Anotação:
Consulte as páginas do Ciclo de Vida do Produto no site de Suporte da Esri para descobrir o status de suporte de cada versão lançada do ArcGIS Runtime SDK for Qt.

O ArcGIS Runtime SDK for Qt versões 10.2.6 e 100.x pode suportar o TLS 1.2 usando a versão mínima suportada do Qt Framework (listada nos Requisitos do Sistema) ou superior e, no mínimo, o OpenSSL 1.0.1 ou superior, em plataformas Windows, Linux e Android. A partir do Qt 5.5, o iOS e o macOS suportam o TLS 1.2 por padrão com a estrutura SecureTransport da Apple.

Requisitos recomendados:

  • Versão mais recente do Qt Framework (ou pelo menos a versão mínima suportada pelo ArcGIS Runtime SDK for Qt)
  • OpenSSL 1.01 ou superior para Windows, Android e Linux
Anotação:
Veja a Página de Esri Suporta TLS para obter informações sobre como usar o TLS 1.2 com outros produtos da Esri.

Related Information

Last Published: 11/14/2018

Article ID: 000019416