Português

Instruções: Configurar o Windows para usar o TLS 1.2 no ArcGIS Desktop

Summary

Anotação:
Esta é uma solução opcional para configurar o TLS 1.2 no ArcGIS Desktop. Para ver uma descrição das outras opções, incluindo a recomendada, consulte: FAQ: Como habilito o TLS 1.2 no ArcGIS Desktop?

Como parte da melhoria da segurança do ArcGIS Online, a Esri exige conexões TLS 1.2 para os serviços do ArcGIS Online. É necessária uma ação para garantir o acesso contínuo aos esses serviços.

Os métodos abaixo descrevem como configurar o sistema operacional Windows para usar o TLS 1.2. Isso permite que todos os aplicativos no sistema que dependem do Microsoft .NET Framework usem o TLS 1.2.

Anotação:
A Esri certificou-se de que essa configuração do ambiente .NET para ativar o TLS 1.2 não cause problemas com o ArcGIS, mas isso pode afetar outros aplicativos .NET,  alterando o comportamento padrão do TLS. Consulte um profissional de sistemas qualificado de computador, se necessário.

Procedure

Anotação:
Após configurar e testar o ArcGIS Desktop para usar o TLS 1.2, retorne à Página de Suporte da Esri sobre TLS para obter instruções sobre como usar o TLS 1.2 com outros produtos da Esri.

As etapas usar o TLS 1.2 no Windows dependem da versão do .NET Framework instalada no sistema. A Esri recomenda utilizar o .NET4, se possível.

  1. Verifique qual versão do .NET está sendo usada. Essa informação pode ser obtida no seguinte documento de Ajuda da Microsoft:
    Instruções: Determinar quais versões do .NET Framework estão instaladas.
  2. Se o .NET4 já estiver instalado, siga estas etapas para configurar o TLS 1.2 no sistema operacional Windows:
    1. Baixe o arquivo zip: TLS_NET4.zip.
    2. Extraia o conteúdo do arquivo zipado e clique duas vezes em TLS_NET4.reg para criar as chaves apropriadas de Registro do Windows.
    3. Teste sua conexão TLS 1.2 com o ArcGIS Online.
  3. Se o .NET4 não estiver instalado no sistema, a Esri recomenda instalá-lo:
    1. Baixe-o e instale-o a partir do Microsoft Download Center.
      Microsoft .NET Framework 4.7 (Instalador da Web).
    2. Siga as etapas na Seção B acima.
  4. Se o sistema estiver usando o .NET Versão 3.5.1 e não for possível fazer upgrade para o .NET4, realize as seguintes etapas para habilitar o TLS 1.2:
    1. Instale as atualizações da Microsoft para habilitar o TLS 1.2. A Microsoft recomenda instalar todas as atualizações do sistema operacional. Consulte as Melhores práticas sobre o Transport Layer Security (TLS) com o .NET Framework: Requisitos para oferecer suporte ao TLS 1.2 com o .NET Framework 3.5
      As seguintes atualizações do TLS 1.2 estão disponíveis:
    2. Baixe o seguinte arquivo zip: TLS_NET35.zip.
    3. Extraia o arquivo TLS_NET35.reg e clique duas vezes para criar as chaves apropriadas de Registro do Windows.
    4. Teste sua conexão TLS 1.2 com o ArcGIS Online.
Anotação:
Consulte as páginas do Ciclo de Vida do Produto no site de Suporte da Esri para descobrir o status de suporte de cada versão lançada do ArcGIS Desktop.

Related Information

Last Published: 4/26/2019

Article ID: 000019328

Software: ArcMap 10.6.1, 10.6