Português
Continue in the app
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

FAQ: As ferramentas de linha de comando do ArcSDE podem ser usadas em bancos de dados geográficos 10.3, 10.3.1, 10.4, 10.4.1 e 10.5?

Question

As ferramentas de linha de comando do ArcSDE podem ser usadas em bancos de dados geográficos 10.3, 10.3.1, 10.4, 10.4.1 e 10.5?

Answer

Os comandos de administração do ArcSDE não estão mais disponíveis a partir da versão ArcGIS 10.3 for Server.

Recomenda-se que os fluxos de trabalho usando as ferramentas de linha de comando ArcSDE sejam migrados para soluções fornecidas na interface do usuário para ArcGIS Desktop e as funções ArcPy disponíveis.

Nota: A funcionalidade de fluxos de trabalho adicionais que foram concluídos anteriormente usando ferramentas de linha de comando continua a ser desenvolvida.
Aqui estão algumas dicas para manter em mente:
  • As ferramentas de linha de comando são suportadas para acessar e interagir com lançamentos de geodatabase até a versão 10.2.2.
  • Os clientes do ArcGIS podem ser atualizados para 10.3/10.3.1/10.4/10.4.1/10.5 e ainda conectar a um geodatabas 10.2.2. Consulte a página de compatibilidade de banco de dados e cliente.
  • Após atualizar o banco de dados geográfico para a versão 10.2.2, é recomendado usar funções ou ferramentas ArcPy na interface do usuário para interagir com o banco de dados geográfico.
  • Para revisar os fluxos de trabalho que atualmente não estão disponíveis na interface do usuário para soluções alternativas ou para registrar um aprimoramento, entre em contato com os Serviços de Suporte da Esri.
  • As ferramentas de linha de comando não estão mais sendo lançadas como download para as versões 10.3 e mais recentes, portanto, nenhuma correção será feita para comportamento inesperado usando essas ferramentas.
Nota: Se não houver substituições atuais para fluxos de trabalho de linha de comando no ArcGIS for Desktop, as ferramentas de linha de comando 10.2.2 continuarão a ter compatibilidade com os bancos de dados 10.3/10.3.1/10.4/10.4.1/10.5 com as seguintes limitações:
  • As ferramentas de linha de comando do ArcSDE só serão suportadas quando usadas conforme pretendido, como um aplicativo cliente autônomo para seus bancos de dados geográficos ArcGIS (que pode ser um geodatabase 10.2.2, 10.3, 10.3.1, 10.4, 10.4.1 ou 10.5.x).
  • As bibliotecas não devem ser misturadas com outros aplicativos do ArcGIS.
  • Os comandos, por exemplo sdeexport/sdeimport, só serão suportados com coleções existentes de tipos de dados que estão disponíveis com 10.2.2, 10.3, 10.3.1, 10.4, 10.4.1, e 10.5. Se novos tipos de dados da Esri forem disponibilizados em versões futuras (por exemplo, inteiros de 64 bits), eles não serão suportados.
  • Os comandos só serão suportados com conexão direta.

Related Information

Last Published: 11/25/2020

Article ID: 000013590

Software: ArcGIS GeoAnalytics Server 10.8.1, 10.8, 10.7.1, 10.7, 10.6.1, 10.6, 10.5.1, 10.5