ERRO

Não foi possível processar a solicitação. java.net.SocketException: Conexão redefinida por par: erro de gravação do soquete

Last Published: April 25, 2020

Mensagem de Erro

Quando há um problema de rede, o seguinte erro geralmente é retornado nos logs do ArcGIS Server.

"Não foi possível processar a solicitação. java.net.SocketException: Conexão redefinida pelo par: erro de gravação do soquete"
[O-Image]

Causa

Veja a seguir as possíveis causas para o erro:

  • O erro ocorre quando uma conexão é fechada abruptamente (quando uma conexão TCP é redefinida enquanto ainda há dados no buffer de envio). A condição é muito semelhante a "Conexão redefinida por par", que é muito comum. Pode acontecer esporadicamente ao se conectar pela Internet, mas que ocorre sistematicamente quando atende aos requisitos de tempo (por exemplo, com conexões keep-alive no host local).
  • O soquete do Protocolo de Controle de Transmissão (TCP) está fechado porque recebeu um comando "fechar" de uma máquina remota de banco de dados.
  • Um pacote de redefinição (RST) é recebido de uma máquina remota e interrompe a conexão estabelecida. Os pacotes de RST enviados podem indicar se os pacotes de TCP transmitidos não foram reconhecidos, uma conexão entre a máquina local e remota de banco de dados local foi interrompida ou uma porta específica está fechada e não permite a comunicação.
  • O banco de dados está sujeito a um tempo limite ou à reinicialização. Se houver um tempo limite inativo ou se a máquina com o banco de dados for reiniciada, o banco de dados ficará inacessível.

Solução ou Solução Provisória

Execute o comando ping para determinar se a máquina remota está acessível.

  1. Vá até o menu Iniciar do Windows.
  2. Digite cmd na barra de pesquisa Pesquisar programas e arquivos .
  3. Clique em cmd nos resultados da pesquisa.
    [O-Image]
  4. Na linha de comando, digite ping , seguido pelo endereço do servidor remoto, e pressione Enter. O seguinte é um exemplo de uma solicitação ping bem-sucedida.
    [O-Image]
    Anotação:
    Mesmo se os resultados forem bem-sucedidos, em alguns casos a máquina de destino não responderá e ainda assim retornará um resultado de ping bem-sucedido. Os dados retornados podem ajudar a determinar se há algum problema de comunicação entre a máquina remota e a máquina local.
  5. Execute o comando tracert para diagnosticar se e onde está ocorrendo o lapso nas comunicações:
    1. Siga as etapas 1 a 3 acima.
    2. Na Etapa 4, digite tracert na linha de comando, seguido pelo endereço de destino, e pressione Enter. O seguinte é um exemplo de uma solicitação tracert bem-sucedida.
    [O-Image]
    Anotação:
    O comando tracert é semelhante ao comando ping, mas exibe em detalhes todas as rotas seguidas para estabelecer uma conexão com a máquina de destino.
  6. Execute o comando telnet para verificar se as portas estão abertas na máquina local.
    1. Siga as etapas 1 a 3 acima.
    2. Na Etapa 4, digite tracert na linha de comando, seguido pelo endereço de destino. Ele pode ser o nome do computador local ou o endereço IP, seguido pelo número da porta. Pressione Enter.
    [O-Image]
    Anotação:
    Se a solicitação for bem-sucedida, a tela ficará em branco, indicando que a porta está aberta. No entanto, se a porta estiver fechada, a seguinte mensagem será retornada. 
    [O-Image]
    Anotação:
    O recurso telnet pode ser ativado em uma máquina Windows navegando para Windows Iniciar > Painel de Controle > Programas (e Recursos). Na barra lateral esquerda, clique em Ativar ou desativar recursos do Windows e verifique se a caixa de seleção Cliente Telnet está marcada. Clique em OK.
  7. Execute SDEINTERCEPT para diagnosticar problemas de desempenho e conexão do ArcSDE. O documento técnico a seguir descreve esse processo em detalhes:
    Instruções: Diagnosticar problemas de desempenho e conexão do ArcSDE usando SDEINTERCEPT.
    Anotação:
    Se a causa do problema for identificada como sendo o servidor de banco de dados, entre em contato com um administrador de banco de dados (DBA) para obter solução de problemas.

ID do Artigo:000012876

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download