Português

Instruções: Importar as tabelas de dados XY para o ArcMap e convertê-los em dados de shapefile usando o ArcMap 10.0 e versões anteriores

Summary

Anotação: 
As informações neste artigo se aplicam apenas ao ArcGIS versões 10.0 e anteriores. Versões posteriores do ArcGIS podem conter diferentes funcionalidades, bem como diferentes nomes e locais para menus, comandos e ferramentas de geoprocessamento. Para executar essas ações no ArcGIS 10.1 e versões posteriores, consulte: Instruções: Importar dados XY para o ArcMap e convertê-los em shapefile ou classe de feição no ArcMap 10.1 e versões posteriores

O ArcMap (e o ArcGIS Pro) não podem ler dados em graus-minutos-segundos (DMS) e, portanto, esses dados devem ser convertidos em graus decimais (DD) antes da importação.

As etapas abaixo fornecem instruções sobre como formatar dados XY em graus decimais usando o Microsoft Excel e converter esses dados em uma shapefile ou classe de feição de geodatabase no ArcMap.

O ArcMap pode ler vários formatos de tabela para aplicar os dados de pontos como um tema de evento.

Anotação:
Na versão 9.1 e anterior, o ArcMap pode ler os seguintes formatos: DBase III, DBase IV, .prn, .txt e .csv. As folhas extras, se houver, devem ser excluídas desses formatos no Excel.
Anotação:
Na versão 9.2 e posteriores, o ArcMap pode ler os formatos acima, além de planilhas .xls e .xlsx. Nas versões mais recentes do Excel, os formatos de arquivo DBase III e DBase IV (.dbf) não são mais suportados.

Procedure

  1. Para garantir que o ArcMap leia os dados no arquivo corretamente, use o Excel para formatar as colunas que contêm os valores de Longitude (X ou Leste) e Latitude (Y ou Norte) como NÚMERO, com um mínimo de 8 casas decimais.

    Descrições do conteúdo de cada coluna são necessárias no arquivo de saída. Identifique as colunas ID, Longitude, Latitude, Descrição, etc.
O gráfico abaixo mostra a distribuição dos valores positivos e negativos para as coordenadas de longitude (X) e latitude (Y) no mundo todo.

[O-Image] Decimal degree coordinates and signs
  1. Após formatar o arquivo, selecione todas as células nas linhas e colunas preenchidas na tabela e navegue até Arquivo > Área de Impressão > Definir Área de Impressão ou Layout da Página > Área de Impressão > Definir Área de Impressão.
    • Nas versões posteriores do Excel, as opções da Área de Impressão estão na guia Layout da Página.
  2. Navegue para Arquivo > Salvar Como e selecione um formato suportado entre as opções disponíveis no Excel. Clique em Sim se o Excel informar que determinada formatação não é suportada nesse formato de arquivo.
  3. Saia do Excel. Clique em Não quando o Excel perguntar se você quer salvar as alterações.
Anotação:
Se as alterações forem salvas, o Excel converte o arquivo em um Livro de Tarefas .xls ou .xlsx que só pode ser usada no ArcMap na versão 9.2 e mais recentes.
  1. Para adicionar os dados de um arquivo .dbf, .csv, .txt ou .prn ao ArcMap, navegue até Ferramentas > Adicionar Dados XY e selecione-o.
    • Na versão 10.0, clique no botão Adicionar Dados.
  2. Clique com o botão direito no nome da tabela e selecione Exibir Dados XY.
Aviso:
Na versão 10.0, o ArcMap aplica o sistema de coordenadas da Estrutura de Dados aos Dados XY. É provável que este sistema de coordenadas esteja incorreto para os dados.
Clique no botão Editar para abrir a caixa de diálogo Propriedades de Referência Espacial. Clique no botão Selecionar para escolher um sistema de coordenadas para os dados.
Anotação:
Se for exibida uma mensagem de aviso referente ao campo ID do Objeto ausente, ignore-a e clique em OK. 
[O-Image]

Como exemplo, os dados de GPS são geralmente coletados em unidades de graus decimais ou lat/long, que é um sistema de coordenadas geográficas. Abra esse diretório. Normalmente, os dados de GPS são coletados no datum WGS 1984, então abra a pasta World e selecione WGS_1984.prj.

Se os dados foram coletados em um datum diferente, clique no link Sistemas de Coordenadas Geográficas e Áreas de Uso na seção Informações Relacionadas abaixo para encontrar o datum apropriado.

  1. Após definir a projeção, clique em Adicionar, Aplicar e OK na caixa de diálogo Propriedades de Referência Espacial. Clique em OK na caixa de diálogo Adicionar Dados XY. Os pontos são desenhados como um tema do evento no ArcMap. Verifique se ele está alinhado com os outros dados no ArcMap.
Anotação:
Se os dados não estiverem alinhados com os dados de referência, consulte o seguinte artigo da Base de Conhecimento: Instruções: Identificar referência espacial, projeções ou sistema de coordenadas de dados.
  1. Para converter o tema do evento em um shapefile ou classe de feição de geodatabase, clique com o botão direito no nome do arquivo e selecione Dados > Exportar Dados. Os pontos podem ser exportados para uma classe de feição de geodatabase ou um shapefile.
  2. Os dados também podem ser reprojetados no sistema de coordenadas da estrutura de dados do ArcMap durante esse processo. Vá para Exibição > Propriedades da Estrutura de Dados > guia Sistema de Coordenadas e selecione a projeção de saída desejada para os dados de saída. Para projetar durante a exportação, clique com o botão direito no tema Eventos, selecione Dados > Exportar Dados e altere o botão de opção para exportar para o "sistema de coordenadas da estrutura de dados. Os dados de saída ficam no sistema de coordenadas de saída selecionado.
  3. Para projetar a camada de eventos em um sistema de coordenadas planas usando a ferramenta Projeto, siga as instruções abaixo:
    1. No ArcMap, navegue até ArcCatalog > Caixas de Ferramentas > Caixas de Ferramentas do Sistema > Ferramentas de Gerenciamento de Dados > Projeções e Transformação > Projeto.
    2. Na caixa de diálogo da ferramenta Projeto, preencha os parâmetros necessários:
      • Conjunto de Dados de Entrada ou Classe de Feição: A classe de feição, a camada de recurso ou o conjunto de dados de feição a ser projetado.
      • Sistema de Coordenadas de Entrada (opcional): O sistema de coordenadas do conjunto de dados ou da classe de feição de entrada.
      • Sistema de Coordenadas de Saída: o sistema de coordenadas no qual os dados de entrada devem ser projetados.
      • Transformação Geográfica (opcional): Usada para converter dados entre dois sistemas de coordenadas geográficas ou datums.
    3. Clique em OK.
Anotação:
Se o ArcMap mostrar um aviso sobre um "sistema de coordenadas geográficas diferente dos outros dados no mapa", navegue até guia Exibição > Propriedades da Estrutura de Dados > Sistema de Coordenadas e clique no botão Transformações para verificar se a transformação de datum correta está sendo usada para a área onde os dados estão localizados.
Anotação:
Para obter uma lista de transformações geográficas (datum) e suas áreas de uso, consulte o seguinte artigo, Instruções: Selecionar a transformação geográfica (datum) correta ao projetar entre datums. Na seção Informações Relacionadas do artigo, baixe a lista de transformações para a versão do ArcGIS Desktop instalada no computador.

Related Information

Last Published: 6/30/2021

Article ID: 000012745

Software: ArcGIS for Desktop Advanced 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS for Desktop Basic 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS for Desktop Standard 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS-ArcEditor 9.3.1, 9.3, 9.2, 9.1, 9.0, 8.3, 8.2, 8.1.2, 8.1, 10 ArcGIS-ArcInfo 9.3.1, 9.3, 9.2, 9.1, 9.0, 8.3, 8.2, 8.1.2, 8.1, 8.0.2, 8.0.1, 10 ArcGIS-ArcView 9.3.1, 9.3, 9.2, 9.1, 9.0, 8.3, 8.2, 8.1.2, 8.1, 10