Português

Instruções: Exibir um arquivo de desenho do AutoCAD no ArcMap

Summary

Este artigo fornece instruções sobre como adicionar arquivos de desenho do AutoCAD ao ArcMap e identificar e corrigir problemas que podem impedir de criar desenhos com os dados no AutoCAD.

Procedure

As etapas a seguir são úteis quando aplicadas a um arquivo de desenho do AutoCAD no aplicativo nativo que ainda não tenha sido adicionado ao ArcMap.

Anotação:
O ArcGIS Desktop não suporta feições criadas no AutoCAD Civil 3D ou no AutoCAD Land Desktop usando dados de Objeto. Se esses arquivos forem abertos e salvos novamente no AutoCAD, alguns dos dados de Objeto poderão ser convertidos em entidades que desenham no ArcMap ou em um geodatabase. Se possível, evite usar dados de Objeto nos arquivos do AutoDesk que são enviados para o ArcGIS Desktop.
  1. Crie uma cópia de um arquivo do AutoCAD.
    1. Salve uma cópia do arquivo de desenho no AutoCAD com um nome sem espaços ou hífens. Se ele tiver esses elementos, substitua-os por sublinhados.
    2. Navegue até Inserir > Referências Externas e desanexe todas as referências externas anexadas ao arquivo. Salve o arquivo de desenho do AutoCAD novamente.
    3. Navegue até Formato > Unidades. Anote as unidades usadas para criar o arquivo.
    4. Navegue até Gerenciador de Camada e ative, descongele ou desbloqueie as camadas que estão desativadas, congeladas ou bloqueadas. Isso permite que os dados sejam desenhados no ArcMap.
    5. Salve o arquivo de desenho do AutoCAD.
  2. Adicione o arquivo de desenho do AutoCAD ao ArcMap para modificar as feições.
    1. Abra um mapa em branco no ArcMap.
[O-Image]
  1. Navegue até a barra de ferramentas Ferramentas e selecione o menu suspenso Adicionar Dados.
[O-Image]
  1. Navegue até o local onde a nova cópia do arquivo de desenho do AutoCAD foi salva e clique duas vezes no arquivo .dwg.
[O-Image]
  1. Adicione cada tipo de feição do arquivo individualmente. Isso ajuda a isolar o(s) tipo(s) de feição que estão causando problemas.
[O-Image]
Anotação:
 Ao adicionar tipos de feição individualmente ao ArcMap, você pode acessar propriedades de camadas individuais. Incluir a camada de grupo bloqueia o acesso a essas informações.
Aviso:
Se surgirem problemas com os dados exibidos na sessão do ArcMap, o arquivo de desenho do AutoCAD deverá ser alterado. Consulte as etapas 3 a 5.
  1. No ArcMap, remova as camadas problemáticas dos arquivos .dwg. Clique com o botão direito em uma camada específica e selecione Remover.
[O-Image] [O]
 
  1. No AutoCAD, navegue até Editar > Selecionar tudo e aplique o comando Explodir para explodir os blocos.
Anotação:
 O comando Explodir pode fazer com que as feições inacessíveis fiquem disponíveis. Recomenda-se aplicar o comando Explodir pelo menos uma vez, embora o comando possa precisar ser aplicado várias vezes mais, uma vez que os blocos podem ser incorporados até nove níveis de profundidade 
  1. Salve o arquivo de desenho no AutoCAD e repita a Etapa 2.

Related Information

Last Published: 11/21/2019

Article ID: 000012483

Software: ArcMap 10.8, 10.7.1, 10.7, 10.6.1, 10.6, 10.5.1, 10.5, 10.4.1, 10.4, 10.3.1, 10.3, 10.2.2, 10.2.1, 10.2, 10.1, 10 ArcGIS for AutoCAD 350, 300