PROBLEMA

Não é possível renomear banco de dados geográficos de arquivos no ArcMap

Last Published: November 24, 2020

Descrição

A tentativa de renomear um arquivo geodatabase retorna o seguinte erro:

Erro: Falha ao renomear objeto.

Causa

Há duas causas possíveis:

  • Há um arquivo .lock para o geodatabase. Os arquivos .lock são criados quando um processo acessa o conjunto de dados.
  • O software antivírus impede a renomeação do geodatabase.
Nota: Em alguns casos, os arquivos .lock podem ser deixados na pasta geodatabase posteriormente (por exemplo, quando um processo termina prematuramente.)

Solução ou Solução Provisória

Use uma das soluções a seguir para resolver esse problema.

  • Reinicie o ArcMap para encerrar o processo. Se os arquivos .lock permanecerem após a conclusão do processo, remova os arquivos .lock manualmente. Para obter mais informações, consulte as Perguntas frequentes: Por que os arquivos .lock do arquivo geodatabase permanecem após a conclusão de um processo?
  • Adicione exceções para todos os aplicativos do ArcGIS ao software antivírus.
  • Realoque temporariamente o arquivo .gdb e o arquivo .gdb de cópia de segurança.
    1. Vá até o local da pasta .gdb.
    2. Mova a pasta .gdb para outro local.
    3. Inicie o ArcCatalog.
    4. Copie e cole a pasta .gdb anteriormente realocada no local da pasta principal e renomeie o arquivo.
Nota: Um arquivo geodatabase de cópia de segurança pode ser criado construindo um novo arquivo de geodatabase e carregando os dados desejados na cópia de segurança ou copiando a pasta .gdb em outra unidade.

ID do Artigo:000012446

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download

Informações Relacionadas

Descubra mais sobre este tema