Mensagem de Erro
Em uma implantação com várias máquinas do ArcGIS Enterprise 11.x ou versões anteriores, a impressão de mapas às vezes não funciona corretamente e apresenta um erro. É muito difícil solucionar isso, pois mostra o status "Iniciado" no ArcGIS Server Manager ou no ponto final do Administrador.
Normalmente, as mensagens de erro abaixo são retornadas.
Error executing tool. Export Web Map Task : Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service1_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service2_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service3_Name>/FeatureServer/0.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service4_Name>/FeatureServer/1.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service5_Name>/FeatureServer/0.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task).
An unexpected error occurred while printing from Map Viewer on ArcGIS Enterprise Portal.
Alguns exemplos de como isso aparece ao imprimir de um aplicativo personalizado são mostrados nas capturas de tela a seguir.


Causa
Existem diversos motivos para esse problema.
- A URL padrão do serviço de ferramentas de impressão não está configurada em: Portal do ArcGIS Enterprise > Organização > Configurações > Serviços de utilitários > Impressão
- O Certificado SSL não está configurado corretamente em cada componente do ArcGIS Enterprise.
- Em casos em que há uma separação de máquinas em Zona desmilitarizada (DMZ) ou Zona militarizada (MZ) no ambiente. Por exemplo, os componentes do ArcGIS Enterprise são separados em duas zonas para diferentes níveis de segurança.
- O proxy endereçado é usado para acessar a internet em máquinas ArcGIS Server, caso essa máquina resida em uma MZ onde não haverá internet para acessar as URLs online.
- A comunicação interna entre as máquinas de componente do ArcGIS Enterprise não está ocorrendo corretamente. A conectividade e as portas necessárias devem ser verificadas.
Solução ou Solução Provisória
As etapas abaixo já funcionaram em configurações de alta disponibilidade para ArcGIS Enterprise 11.x.
- Configuração da URL padrão do serviço de ferramentas de impressão em: Portal do ArcGIS Enterprise, guia Organização > Configurações > Serviços de utilitários > Impressão
https://machine.domain.in/arcgis/rest/services/Utilities/PrintingTools/GPServer
- onde "machine.domain.in" é o DNS público configurado para tornar o ArcGIS Enterprise acessível pela internet. Caso contrário, é a URL do Portal do ArcGIS Enterprise.
- Configurando corretamente o Certificado SSL em cada componente do ArcGIS Enterprise:
- Configure o certificado SSL assinado CA ou assinado por domínio aplicável em cada máquina:
- ArcGIS Server (hospedagem) - Cada máquina participante
- Portal do ArcGIS Enterprise - Tanto primário quanto auxiliar
- ArcGIS Datastore - Tanto primário quanto auxiliar
- Quaisquer outros papéis do ArcGIS Server / máquinas federadas com o ArcGIS Enterprise
- Se houver separação DMZ ou MZ entre máquinas no ambiente e o proxy endereçado for usado para acessar a internet em máquinas do ArcGIS Server, configure um servidor proxy endereçado com ArcGIS Server 11.x usando estas etapas:
- Efetue o login na seguinte URL com a conta do administrador do site primário:
https://machine.domain.com:6443/arcgis/admin
- Clique em Sistema > Propriedades > Atualizar
Consulte as instruções abaixo para configurar o proxy endereçado para máquinas Windows e Linux: