Instrução

O serviço PrintingTools produz patches de legenda ilegíveis ou pixelados na saída PDF

Last Published: February 13, 2024

Descrição

Os patches de legenda da camada do serviço de mapa podem aparecer ilegíveis, pixelados ou podem desaparecer quando o serviço PrintingTools é enviado para o formato PDF, EPS ou SVG. Esse problema ocorre frequentemente quando o layout solicitado é maior que o tamanho Carta ou A4. O problema também ocorre com os patches de legenda das camadas de serviço da feição e camadas gráficas por parte do cliente quando um marcador de imagem ou símbolo de preenchimento é utilizado. Imagens ou objetos inseridos, como gráficos de logotipo, podem ser descartados da página.

Um exemplo de um patch de legenda da camada de serviço que aparece distorcido quando exportado para o formato PDF é mostrado abaixo:

[O-Imagem] PixelatedWebMapLegend1

Causa

Se um patch de legenda com um preenchimento de imagem ou tipo de símbolo de marcador estiver fora do tamanho de página padrão da impressora padrão do Windows, as chamadas de desenho GDI do Windows usadas pelo Serviço de Impressão poderão não desenhar corretamente o objeto ou a imagem na saída. O tamanho de página padrão da impressora em uma máquina típica é o tamanho Carta ou A4. A falha de renderização em tamanhos de página de layout grande geralmente ocorre na área da página que está abaixo ou à direita do tamanho menor do papel da impressora. Assim, é mais comum ver esse problema quando a legenda é colocada nas áreas inferior ou direita da página.

Os serviços de mapa renderizam até mesmo símbolos simples, como um círculo, e seus patches de legenda como imagens. Eles são renderizados sem problemas dentro da estrutura de dados, pois são combinados com o desenho do conteúdo da camada de serviço como raster. Mas eles têm problemas de renderização quando desenhados como imagens discretas na página de layout.

Solução ou Solução Provisória

Defina o tamanho de página padrão da impressora padrão do Windows da Conta do ArcGIS Server para um tamanho tão grande ou maior que o layout de página que está sendo exportado. Por exemplo, se o documento de mapa for de tamanho tablóide (11 x 17), defina o tamanho de página padrão da impressora padrão como 11 x 17 ou maior. Se estiver configurando a impressora para o tamanho exato da página de layout, verifique se a orientação (retrato ou paisagem) também corresponde ao layout a ser exportado. A solução mais fácil normalmente é instalar um driver de plotadora, pois eles têm os maiores tamanhos de página disponíveis por padrão. O Microsoft Windows é fornecido com muitos drivers de plotadora disponíveis por meio do assistente Adicionar Impressora. Nenhum download é necessário.

  1. Entre na máquina do servidor como administrador.
  2. Abra o console Serviços do Windows em Iniciar > Painel de Controle > Ferramentas Administrativas > Serviços.
  3. Pare o serviço do ArcGIS Server.
  4. Saia e entre novamente no servidor utilizando a Conta do ArcGIS Server.
Note:
This is the account that was chosen during ArcGIS Server setup. Windows Task Manager can also be used on the server machine to find out which user is being used to run ArcSOC.exe process.
  1. Abra a caixa de diálogo Dispositivos e Impressoras do Windows navegando até Iniciar > Painel de Controle > Dispositivos e Impressoras.
  2. Clique com o botão direito do mouse na impressora padrão; ela contém um ícone de marca de seleção.
  3. Selecione Preferências de impressão.
  4. Na guia Papel/Qualidade , em Opções de Papel, selecione um tamanho de papel maior que o tamanho da página do layout desejado. Clique em OK. O nome e a aparência da caixa de diálogo Propriedades da Impressora podem variar de acordo com a impressora/driver.
  5. Saia e entre novamente como administrador.
  6. Inicie o serviço do ArcGIS Server a partir do console Serviços do Windows aberto na Etapa 2.

ID do Artigo: 000011636

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