PROBLEMA

Não é possível atualizar e publicar pesquisas do ArcGIS Survey123 Connect

Last Published: April 27, 2022

Descrição

Ao usar o ArcGIS Survey123 Connect para publicar uma pesquisa, uma pasta da pesquisa é criada no ArcGIS Online contendo a camada de feição, bem como um item de formulário e um mapa da web. Isso permite flexibilidade na migração do conteúdo do ArcGIS Online. Em alguns casos, ao atualizar e republicar a pesquisa usando o Survey123 Connect, o processo de publicação carrega, mas não é concluído, conforme mostrado na imagem abaixo:

A página de publicação de uma pesquisa no ArcGIS Survey123 Connect que carrega e não é concluída.

Causa

Este problema ocorre quando o item de formulário da pesquisa foi movido para outra pasta no ArcGIS Online. Isso resulta no ID do item da pasta do ArcGIS Online onde o item do formulário não deve corresponder ao ID no arquivo ITEMINFO local da pesquisa.

Quando a pesquisa é publicada originalmente, o ID da pasta do ArcGIS Online onde o item de formulário está armazenado é salvo localmente em um arquivo ITEMINFO. Cada vez que a pesquisa é publicada subsequentemente, o ID no arquivo ITEMINFO deve corresponder ao ID da pasta do ArcGIS Online que armazena o item de formulário.

O item de formulário na pasta do ArcGIS Online que contém o ID que deve corresponder ao ID no arquivo ITEMINFO salvo localmente

Solução ou Solução Provisória

Para resolver o problema, siga as etapas abaixo para editar o arquivo ITEMINFO da pesquisa para garantir que o ID do item corresponda ao ID da pasta do ArcGIS Online onde o item do formulário está armazenado.

  1. No ArcGIS Online, navegue até Conteúdo > Meu Conteúdo.
  2. Vá até a pasta que armazena o item de formulário e copie o ID do item da pasta da barra de endereço do navegador da web, conforme mostrado na imagem abaixo.
A página da pasta de pesquisa exibindo o ID do item da pasta na barra de endereço.
  1. Na máquina local, vá até a pasta de pesquisa e abra o arquivo ITEMINFO da pesquisa com um editor de texto.
O arquivo ITEMINFO da pesquisa, navegando no diretório do Explorador de Arquivos da máquina local.
  1. Procure pelo parâmetro "ownerFolder" e certifique-se de que os valores correspondem ao ID do item na Etapa 2. Se o ID do item for diferente, atualize os valores dos parâmetros com o ID do item copiado na Etapa 2 e clique em Salvar.
Modificar o parâmetro ownerFolder para garantir que ele tenha o mesmo ID do item que o ID do item da pasta de pesquisa no ArcGIS Online.
  1. Publique novamente a pesquisa do Survey123 Connect.

ID do Artigo: 000025001

Receba notificações e encontre soluções para problemas novos ou comuns

Obtenha respostas resumidas e soluções de vídeo do nosso novo chatbot de IA.

Baixe o Aplicativo de Suporte da Esri

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Baixe o Aplicativo de Suporte da Esri

Ir para as opções de download