Instrução

Não é possível salvar símbolos personalizados no Seletor de Símbolos

Last Published: October 1, 2025

Descrição

As caixas de diálogo Seletor de Símbolos mostram uma paleta de símbolos que residem em qualquer um dos estilos referenciados no momento ou nos estilos pessoais de um usuário. Usando o Seletor de Símbolos, os usuários podem implementar símbolos personalizados se nenhum dos símbolos desejados estiver presente na paleta ou for difícil de encontrar.

No entanto, os usuários não poderão salvar símbolos personalizados no Seletor de Símbolos se o botão Salvar Como na caixa de diálogo Seletor de Símbolos estiver desativado.

[O-Image]

Causa

O botão pode ser desativado devido aos seguintes motivos:

  • O arquivo .style é definido como Somente leitura.
  • Há um problema relacionado ao arquivo Normal.mxt.
  • Os dados ou o arquivo MXD estão corrompidos.

Solução ou Solução Provisória

Dependendo da causa, as seguintes soluções alternativas são aplicáveis.

Note:
Close all Esri applications running on the system before proceeding to the workaround.

Verifique se há acesso de leitura e gravação ao arquivo .style

Este arquivo está localizado em:

C:\Users\*username*\AppData\Roaming\ESRI\Desktop10.x\ArcMap
Note:
Enable 'Show Hidden Files and Folders' if unable to locate the application data folder. This can be done in Windows 7 or 8 by clicking Organize Drop-down > Folder and Search Options > View Tab > Show Hidden Files and Folders.
[O-Image]

Renomear o arquivo Normal.mxt

  1. Navegue até o seguinte caminho de diretório:
C:\User\*username*\AppData\Roaming\ESRI\Desktop10.x\ArcMap\Templates
  1. Clique com o botão direito do mouse no arquivo Normal.mxt e clique em Renomear.
  2. Renomeie o arquivo para 'Normal_old.mxt'.
  3. Inicie o ArcMap.
Warning:
The instructions below include making changes to essential parts of the operating system. Esri recommends performing a back up of the operating system and files, including the registry, before proceeding. Consult a qualified computer systems professional if necessary.
Be aware that renaming the Esri folders is a factory reset of ArcGIS, and therefore all third party tools, custom scripts, or custom toolbars currently installed must be reinstalled accordingly. Additionally, all existing folder connections must be reconnected.
Esri cannot guarantee results from incorrect modifications while following these instructions. Proceed with caution.
Note:
If ArcGIS Pro is installed on the machine, ensure that an ArcGIS Pro license is not checked out from ArcGIS Online.
If unsure that the ArcGIS Pro license is checked out on the machine, contact Esri Technical Support at 888-377-4575.

Renomeie a pasta Esri

  1. Abra o Windows Explorer.
  2. Vá até:
C:\Users\*username*\AppData\Roaming\ESRI
  1. Clique com o botão direito do mouse na pasta Esri e selecione Renomear. Renomeie a pasta para 'ESRI_old'.

Editar a chave do Registro

  1. Clique no menu Iniciar > Executar > digite regedit.
  2. No Editor de Registro , expanda a pasta HKEY_CURRENT_USER.
  3. Expanda a pasta Software .
  4. Renomeie a pasta Esri para 'Esri_old'.
[O-Image]
  1. Feche a janela do Editor do Registro.
  2. Inicie o ArcMap.

ID do Artigo: 000012396

Receba notificações e encontre soluções para problemas novos ou comuns

Obtenha respostas resumidas e soluções de vídeo do nosso novo chatbot de IA.

Baixe o Aplicativo de Suporte da Esri

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Baixe o Aplicativo de Suporte da Esri

Ir para as opções de download