Instrução

A ferramenta Validação e Reparo para de responder ou falha durante a desinstalação do patch do Portal for ArcGIS

Last Published: July 29, 2024

Descrição

Ao executar a ferramenta Validação e Reparo do Portal for ArcGIS, a janela de ferramentas para de responder ou falha ao desinstalar patches. A verificação da atividade do sistema operacional (SO) não revela nenhum processo em segundo plano em andamento.

Os seguintes logs são retornados nos logs do Visualizador de Eventos do Windows correspondentes a cada falha:

Os logs do Visualizador de Eventos do Windows correspondentes a cada falha

Em determinados casos, a seguinte mensagem de erro é retornada na janela Validação e Reparo do Portal for ArcGIS 10.8.1:

Error:
There were issues uninstalling patches from your portal machine.
A mensagem de erro na janela da ferramenta Validação e Reparo do Portal for ArcGIS 10.8.1

Ao tentar desinstalar os patches do Painel de Controle do Microsoft Windows, a seguinte mensagem de erro é retornada:

Error: 
The feature you are trying to use is on a network resource that is unavailable.
Note: 
The patches uninstallation process for Portal for ArcGIS 10.8.1 or 10.9.1 taking a longer time is anticipated. Refer to Patches and Updates: Portal for ArcGIS Validation and Repair for more information.

Causa

  • O software antivírus instalado na máquina bloqueia ou limita o acesso a um ou mais arquivos de patch. A conexão com os arquivos de patch pode ser bloqueada por regras de segurança pré-determinadas definidas pela organização.
  • A ferramenta Validação e Reparo não pode procurar o arquivo de instalação original do Portal for ArcGIS.

Solução ou Solução Provisória

Dependendo da circunstância, as soluções alternativas descritas abaixo são aplicáveis.

Desativar o software antivírus e interrompa as tarefas restantes

Entre em contato com o departamento de TI para desativar o software antivírus e executar novamente a ferramenta Validação e Reparar. Se isso não resolver o problema, aplique as etapas a seguir para interromper as tarefas na janela do Gerenciador de Tarefas e executar novamente a ferramenta Validação e Reparo.

  1. Pressione as teclas Windows + X e selecione Gerenciador de Tarefas no menu. A janela Gerenciador de Tarefas é aberta.
  2. Na guia Processos , selecione a ferramenta Validação e Reparo e clique em Finalizar tarefa.
  3. Selecione 7za.exe e clique em Finalizar tarefa.
  4. Feche a janela Gerenciador de Tarefas.
  5. Execute a ferramenta Validação e Reparo .

Execute a ferramenta Validação e Reparo no prompt de comando

Aplique as etapas a seguir se desabilitar o software antivírus não for uma opção viável.

  1. Na caixa de pesquisa do Windows na barra de tarefas, pesquise e clique com o botão direito em Prompt de Comando do Windows e selecione Executar como administrador.
  2. Na janela Administrador: Prompt de Comando , execute o seguinte comando para alterar o diretório no Prompt de Comando para o diretório que contém a ferramenta Validação e Reparo.
C:/<ArcGIS Server installation directory>\<download folder>
  1. Execute a ferramenta Validação e Reparo inserindo o nome da ferramenta na linha de comando.
ArcGIS-PFA-1081-ValidationRepair.exe
O comando na janela Administrador do Windows: Prompt de Comando

Extrair o arquivo de instalação do portal para o local correto do arquivo

Para resolver a mensagem de erro, extraia ou baixe o arquivo de instalação do portal para o caminho definido na propriedade SourceDir no Registro do Windows. O caminho padrão para o arquivo do instalador extraído é:

C:\Users\<user profile ID>\Documents\ArcGIS 10.8.1\PortalForArcGIS\SetupFiles
  1. Localize o local do arquivo de instalação do Portal for ArcGIS:
    1. Na caixa de pesquisa do Windows na barra de tarefas, pesquise e clique em Editor do Registro.
    2. Na janela Editor do Registro , copie o seguinte caminho de arquivo para a caixa Localizar .
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\Portal for ArcGIS
A caixa Localizar na janela Editor do Registro
  1. Identifique o caminho do arquivo registrado na coluna Dados da propriedade SourceDir .
O caminho de arquivo do Portal for ArcGIS na coluna Dados da propriedade SourceDir
  1. Baixe o arquivo de instalação do Portal for ArcGIS e execute o arquivo para extraí-lo na pasta SourceDir. Consulte Instrução: Baixar e instalar o software do My Esri para obter instruções.
Warning:
Do not run the setup file after the extraction is completed. Doing so may result in overwriting the existing deployment.
  1. Execute a ferramenta Validação e Reparo .

ID do Artigo: 000032123

Obtenha suporte com IA

Resolva seu problema rapidamente com o chatbot de IA de suporte da Esri.

Comece a conversar agora

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Comece a conversar agora

Ir para as opções de download