PROBLEMA

A lista de opções externa está indisponível no ArcGIS Survey123 web app

Last Published: October 20, 2022

Descrição

Usar uma lista de opções externa é uma opção ideal quando a lista de opções é gerenciada fora do ArcGIS Survery123, ou se a lista de opções for grande. Em alguns casos, enquanto a lista de opções externa está acessível no ArcGIS Survey123 Connect e no ArcGIS Survey123 field app, a lista não está disponível ao visualizar a pesquisa no ArcGIS Survey123 web app. Dependendo da causa, uma das seguintes mensagens de erro é retornada:

Erro: Inicializando o formulário… TypeError: Não é possível ler a propriedade 'textContent' de nulo
Mensagem de erro retornada ao visualizar a pesquisa no ArcGIS Survey123 web app.
Erro: Inicializando o formulário… O cabeçalho da coluna "field_name" do CSV não pode ser transformado em um elemento XML válido
Mensagem de erro retornada ao visualizar a pesquisa no ArcGIS Survey123 web app.
Erro: Inicializando o formulário… Falha ao carregar dados de <fonte_dados>
Mensagem de erro retornada ao visualizar a pesquisa no ArcGIS Survey123 web app.

Causa

A seguir estão as causas conhecidas do problema:

  • Os nomes dos campos no arquivo CSV referenciado contêm espaços, caracteres especiais ou caracteres maiúsculos.
  • O arquivo CSV não contém o nome ou a coluna de rótulo.
  • O arquivo CSV contém colunas vazias.
  • O nome do arquivo CSV não corresponde ao nome da lista de opções da pergunta select_one_from_file ou select_multiple_from_file no XLSForm da pesquisa.

Solução ou Solução Provisória

Dependendo da causa, use uma das opções abaixo para resolver o problema.

Certifique-se que os nomes dos campos não incluam caracteres especiais, caracteres maiúsculos ou espaços

  • Exclua os caracteres especiais, como barras (/) de nomes dos campos.
  • Substitua as letras maiúsculas nos nomes dos campos por letras minúsculas.
  • Substitua os espaços nos nomes dos campos por sublinhados.
Certifique-se que o arquivo CSV contenha as colunas de nome e rótulo e não contenha colunas vazias
  • O arquivo CSV deve conter as colunas de nome e rótulo.
O nome e colunas do rótulo.
  • Remova as colunas vazias do arquivo CSV.

Certifique-se que o nome da lista de opções no tipo de pergunta corresponda ao nome do arquivo CSV

No XLSForm do ArcGIS Survey123 Connect, certifique-se que o nome da lista de opções externa na pergunta select_one_from_file ou select_multiple_from_file corresponda ao arquivo CSV referenciado. Os nomes dos arquivos CSV diferenciam letras maiúsculas de minúsculas e não permitem espaços.

O nome da lista de opções externas na pergunta que corresponde ao arquivo CSV de referência.

A imagem abaixo mostra a lista de opções externa disponível no ArcGIS Survey123 web app.

A lista de opções externa no ArcGIS Survey123 web app quando o arquivo CSV de referência é configurado corretamente no ArcGIS Survey123 Connect.

ID do Artigo: 000025209

Receba notificações e encontre soluções para problemas novos ou comuns

Obtenha respostas resumidas e soluções de vídeo do nosso novo chatbot de IA.

Baixe o Aplicativo de Suporte da Esri

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Baixe o Aplicativo de Suporte da Esri

Ir para as opções de download